# CVE-2021-25959: OpenCRX - Reflected Cross-Site Scripting in Password Reset Functionality

> Attackers can execute arbitrary JavaScript in victims' browsers via unsanitized password reset parameters, potentially leading to session hijacking or account takeover.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Sep 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-rwh9-8xx8-4wfm

## What is CVE-2021-25959?

CVE-2021-25959 is a medium-severity cross-site scripting vulnerability in org.opencrx opencrx-core-config, published on 29 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the password reset functionality. This allows execution of external javascript files on any user of the openCRX instance.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-25959?

10 open source packages ship an affected version, including org.opencrx:opencrx-core-config, org.opencrx:opencrx-client and org.opencrx:opencrx-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencrx:opencrx-core-config` | Maven | From 4.0.0 | 5.2.0 |
| `org.opencrx:opencrx-core-config` | Maven | From 4.0.0 | 5.2.0 |
| `org.opencrx:opencrx-client` | Maven | From 4.0.0 | 5.2.0 |
| `org.opencrx:opencrx-client` | Maven | From 4.0.0 | 5.2.0 |
| `org.opencrx:opencrx-core` | Maven | From 4.0.0 | 5.2.0 |
| `org.opencrx:opencrx-core` | Maven | From 4.0.0 | 5.2.0 |
| `org.opencrx:opencrx-core-models` | Maven | From 4.0.0 | 5.2.0 |
| `org.opencrx:opencrx-core-models` | Maven | From 4.0.0 | 5.2.0 |
| `org.opencrx:opencrx-gradle` | Maven | From 4.0.0 | 5.2.0 |
| `org.opencrx:opencrx-gradle` | Maven | From 4.0.0 | 5.2.0 |

Products: Opencrx Opencrx.

## How do I fix CVE-2021-25959?

Upgrade org.opencrx:opencrx-core-config to 5.2.0 or later.

## Is CVE-2021-25959 being exploited?

There is no known exploitation of CVE-2021-25959 in the wild and no public exploit code.

## Other vulnerabilities in org.opencrx opencrx-core-config

- [CVE-2023-46502](https://insights.sbomify.com/CVE-2023-46502/): OpenCRX allows a remote attacker to execute arbitrary code via a crafted request (critical 9.8)
- [CVE-2020-7378](https://insights.sbomify.com/CVE-2020-7378/): CRIXP OpenCRX Unverified Password Change (critical 9.1)
- [CVE-2023-27151](https://insights.sbomify.com/CVE-2023-27151/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2023-40809](https://insights.sbomify.com/CVE-2023-40809/): Cross-site Scripting in OpenCRX (medium 6.1)
- [CVE-2023-40810](https://insights.sbomify.com/CVE-2023-40810/): Cross-site Scripting in OpenCRX (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-25959 and fix it if it is affected.

What it is: CVE-2021-25959 is a medium-severity cross-site scripting vulnerability in org.opencrx opencrx-core-config, published on 29 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-25959 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opencrx:opencrx-core-config (Maven): affected from 4.0.0; fixed in 5.2.0
- org.opencrx:opencrx-core-config (Maven): affected from 4.0.0; fixed in 5.2.0
- org.opencrx:opencrx-client (Maven): affected from 4.0.0; fixed in 5.2.0
- org.opencrx:opencrx-client (Maven): affected from 4.0.0; fixed in 5.2.0
- org.opencrx:opencrx-core (Maven): affected from 4.0.0; fixed in 5.2.0
- org.opencrx:opencrx-core (Maven): affected from 4.0.0; fixed in 5.2.0
- org.opencrx:opencrx-core-models (Maven): affected from 4.0.0; fixed in 5.2.0
- org.opencrx:opencrx-core-models (Maven): affected from 4.0.0; fixed in 5.2.0
- org.opencrx:opencrx-gradle (Maven): affected from 4.0.0; fixed in 5.2.0
- org.opencrx:opencrx-gradle (Maven): affected from 4.0.0; fixed in 5.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-25959/ (Markdown: https://insights.sbomify.com/CVE-2021-25959/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-25959
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-25959
- OSV: https://osv.dev/vulnerability/CVE-2021-25959

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-25959/
Summaries are generated and may contain mistakes; the official description above is the record.
