CVE-2021-25963 Shuup - Reflected XSS in Error Page
Attackers can execute arbitrary JavaScript in victim browsers via unescaped error page content in Shuup.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-25963?
CVE-2021-25963 is a medium-severity cross-site scripting vulnerability in shuup, published on 30 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In Shuup, versions 1.6.0 through 2.10.8 are vulnerable to reflected Cross-Site Scripting (XSS) that allows execution of arbitrary javascript code on a victim browser. This vulnerability exists due to the error page contents not escaped.
Weakness: CWE-79
Which versions are affected by CVE-2021-25963?
3 open source packages ship an affected version, including shuup. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
shuup PyPI | From 1.6.0 | 2.11.0 |
shuup PyPI | From 1.6.0 | 2.11.0 |
shuup PyPI | From 1.6.0 | 2.11.0 |
Products include Shuup Shuup.
How do I fix CVE-2021-25963?
Upgrade shuup to 2.11.0 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-25963 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25963 exists.
Other vulnerabilities in shuup
Sources
Also known as GHSA-5pcx-vqjp-p34w, PYSEC-2021-350.