# CVE-2021-25963: Shuup - Reflected XSS in Error Page

> Attackers can execute arbitrary JavaScript in victim browsers via unescaped error page content in Shuup.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Sep 2021
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-5pcx-vqjp-p34w, PYSEC-2021-350

## What is CVE-2021-25963?

CVE-2021-25963 is a medium-severity cross-site scripting vulnerability in shuup, published on 30 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Shuup, versions 1.6.0 through 2.10.8 are vulnerable to reflected Cross-Site Scripting (XSS) that allows execution of arbitrary javascript code on a victim browser. This vulnerability exists due to the error page contents not escaped.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-25963?

3 open source packages ship an affected version, including shuup. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shuup` | PyPI | From 1.6.0 | 2.11.0 |
| `shuup` | PyPI | From 1.6.0 | 2.11.0 |
| `shuup` | PyPI | From 1.6.0 | 2.11.0 |

Products: Shuup Shuup.

## How do I fix CVE-2021-25963?

Upgrade shuup to 2.11.0 or later.

## Is CVE-2021-25963 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25963 exists.

## Other vulnerabilities in shuup

- [CVE-2021-25962](https://insights.sbomify.com/CVE-2021-25962/): Shuup - Formula Injection in Checkout Addresses (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-25963 and fix it if it is affected.

What it is: CVE-2021-25963 is a medium-severity cross-site scripting vulnerability in shuup, published on 30 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25963 exists.

Affected packages and fixed versions:
- shuup (PyPI): affected from 1.6.0; fixed in 2.11.0
- shuup (PyPI): affected from 1.6.0; fixed in 2.11.0
- shuup (PyPI): affected from 1.6.0; fixed in 2.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-25963/ (Markdown: https://insights.sbomify.com/CVE-2021-25963/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-25963
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-25963
- OSV: https://osv.dev/vulnerability/CVE-2021-25963

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-25963/
Summaries are generated and may contain mistakes; the official description above is the record.
