CVE-2021-25969 Camaleon CMS - Stored Cross-Site Scripting (XSS) in Comments

Medium 6.1 Published Updated

Unauthenticated attackers can inject malicious scripts into Camaleon CMS comments, leading to code execution in victims' browsers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-25969?

CVE-2021-25969 is a medium-severity cross-site scripting vulnerability in camaleon_cms, published on 20 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

In Camaleon CMS application, versions 0.0.1 to 2.6.0 are vulnerable to stored XSS, that allows an unauthenticated attacker to store malicious scripts in the comments section of the post. These scripts are executed in a victim’s browser when they open the page containing the malicious comment.

Weakness: CWE-79

Which versions are affected by CVE-2021-25969?

2 open source packages ship an affected version, including camaleon_cms. It affects 1 product.

PackageAffectedFixed in
camaleon_cms RubyGemsFrom 0.0.12.6.0.1
camaleon_cms RubyGemsFrom 0.0.12.6.0.1

Products include Tuzitio Camaleon Cms.

How do I fix CVE-2021-25969?

Upgrade camaleon_cms to 2.6.0.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-25969 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25969 exists.

Sources

Also known as GHSA-x78v-4fvj-rg9j.

Is CVE-2021-25969 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free