{"answers":{"affected":"2 open source packages ship an affected version, including camaleon_cms. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25969 exists.","fix":"Upgrade camaleon_cms to 2.6.0.1 or later.","what":"CVE-2021-25969 is a medium-severity cross-site scripting vulnerability in camaleon_cms, published on 20 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-25969 and fix it if it is affected.\n\nWhat it is: CVE-2021-25969 is a medium-severity cross-site scripting vulnerability in camaleon_cms, published on 20 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25969 exists.\n\nAffected packages and fixed versions:\n- camaleon_cms (RubyGems): affected from 0.0.1; fixed in 2.6.0.1\n- camaleon_cms (RubyGems): affected from 0.0.1; fixed in 2.6.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-25969/ (Markdown: https://insights.sbomify.com/CVE-2021-25969/index.md)","id":"CVE-2021-25969","markdown":"https://insights.sbomify.com/CVE-2021-25969/index.md","name":"CVE-2021-25969","record":{"aliases":["GHSA-x78v-4fvj-rg9j"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Camaleon CMS","requires_auth":"none","summary":"Unauthenticated attackers can inject malicious scripts into Camaleon CMS comments, leading to code execution in victims' browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mend","cpe":[{"product":"camaleon_cms","vendor":"tuzitio"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In Camaleon CMS application, versions 0.0.1 to 2.6.0 are vulnerable to stored XSS, that allows an unauthenticated attacker to store malicious scripts in the comments section of the post. These scripts are executed in a victim’s browser when they open the page containing the malicious comment.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Camaleon CMS - Stored Cross-Site Scripting (XSS) in Comments","id":"CVE-2021-25969","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Camaleon CMS - Insufficient Session Expiration after Password Change","id":"CVE-2021-25970"},"packages":[{"ecosystem":"RubyGems","fixed":["2.6.0.1"],"introduced":["0.0.1"],"last_affected":[],"package":"camaleon_cms","purl":null,"source":"GHSA-x78v-4fvj-rg9j"},{"ecosystem":"RubyGems","fixed":["2.6.0.1"],"introduced":["0.0.1"],"last_affected":[],"package":"camaleon_cms","purl":"pkg:gem/camaleon_cms","source":"GHSA-x78v-4fvj-rg9j"}],"prev":{"headline":"OpenCMS - Stored Cross-Site Scripting (XSS) in Sitemap","id":"CVE-2021-25968"},"products":["camaleon_cms"],"published":"2021-10-20","related":[{"cvss_score":10,"headline":"Arbitrary file write leading to RCE in Camaleon CMS","id":"CVE-2024-46986","kev_date_added":null,"published":"2024-09-18"},{"cvss_score":9.8,"headline":"Server-Side Template Injection in Camaleon CMS","id":"CVE-2023-30145","kev_date_added":null,"published":"2023-05-26"},{"cvss_score":8.8,"headline":"Camaleon CMS - Insufficient Session Expiration after Password Change","id":"CVE-2021-25970","kev_date_added":null,"published":"2021-10-20"},{"cvss_score":7.7,"headline":"Arbitrary path traversal in Camaleon CMS","id":"CVE-2024-46987","kev_date_added":null,"published":"2024-09-18"},{"cvss_score":6.1,"headline":"Camaleon CMS vulnerable to Stored Cross-site Scripting","id":"CVE-2018-18260","kev_date_added":null,"published":"2018-10-15"},{"cvss_score":6,"headline":"Camaleon CMS AWS Uploader Authenticated Path Traversal Arbitrary File Read","id":"CVE-2026-1776","kev_date_added":null,"published":"2026-03-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-30","vendors":["camaleon_cms"]},"summary":"Unauthenticated attackers can inject malicious scripts into Camaleon CMS comments, leading to code execution in victims' browsers.","url":"https://insights.sbomify.com/CVE-2021-25969/"}