# CVE-2021-25970: Camaleon CMS - Insufficient Session Expiration after Password Change

> Attackers retain access to Camaleon CMS accounts after password changes because active sessions are not terminated, allowing unauthorized continued access.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Oct 2021
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-438x-2p9v-g8h9

## What is CVE-2021-25970?

CVE-2021-25970 is a high-severity vulnerability in camaleon_cms, published on 20 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Camaleon CMS 0.1.7 to 2.6.0 doesn’t terminate the active session of the users, even after the admin changes the user’s password. A user that was already logged in, will still have access to the application even after the password was changed.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2021-25970?

2 open source packages ship an affected version, including camaleon_cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `camaleon_cms` | RubyGems | From 0.1.7 | 2.6.0.1 |
| `camaleon_cms` | RubyGems | From 0.1.7 | 2.6.0.1 |

Products: Tuzitio Camaleon Cms.

## How do I fix CVE-2021-25970?

Upgrade camaleon_cms to 2.6.0.1 or later.

## Is CVE-2021-25970 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25970 exists.

## Other vulnerabilities in camaleon_cms

- [CVE-2024-46986](https://insights.sbomify.com/CVE-2024-46986/): Arbitrary file write leading to RCE in Camaleon CMS (critical 10.0)
- [CVE-2023-30145](https://insights.sbomify.com/CVE-2023-30145/): Server-Side Template Injection in Camaleon CMS (critical 9.8)
- [CVE-2024-46987](https://insights.sbomify.com/CVE-2024-46987/): Arbitrary path traversal in Camaleon CMS (high 7.7)
- [CVE-2021-25969](https://insights.sbomify.com/CVE-2021-25969/): Camaleon CMS - Stored Cross-Site Scripting (XSS) in Comments (medium 6.1)
- [CVE-2018-18260](https://insights.sbomify.com/CVE-2018-18260/): Camaleon CMS vulnerable to Stored Cross-site Scripting (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-25970 and fix it if it is affected.

What it is: CVE-2021-25970 is a high-severity vulnerability in camaleon_cms, published on 20 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25970 exists.

Affected packages and fixed versions:
- camaleon_cms (RubyGems): affected from 0.1.7; fixed in 2.6.0.1
- camaleon_cms (RubyGems): affected from 0.1.7; fixed in 2.6.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-25970/ (Markdown: https://insights.sbomify.com/CVE-2021-25970/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-25970
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-25970
- OSV: https://osv.dev/vulnerability/CVE-2021-25970

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-25970/
Summaries are generated and may contain mistakes; the official description above is the record.
