CVE-2021-25973 Publify - Improper Authorization Leads to Guest Signup Restriction Bypass
Attackers can bypass guest signup restrictions in Publify due to improper authorization checks, allowing unauthorized user registration.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-25973?
CVE-2021-25973 is a medium-severity missing authorization vulnerability in publify_core, published on 2 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Publify, 9.0.0.pre1 to 9.2.4 are vulnerable to Improper Access Control. “guest” role users can self-register even when the admin does not allow. This happens due to front-end restriction only.
Which versions are affected by CVE-2021-25973?
3 open source packages ship an affected version, including publify_core and publify. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
publify_core RubyGems | From 9.0.0.pre1 | 9.2.5 |
publify_core RubyGems | From 9.0.0.pre1 | 9.2.5 |
publify Bitnami | From 9.0.0 | 9.2.4 |
Products include Publify Project Publify.
How do I fix CVE-2021-25973?
Upgrade publify_core to 9.2.5 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-25973 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25973 exists.
Other vulnerabilities in publify_core
- CVE-2022-1810 Authorization Bypass Through User-Controlled Key in publify/publify
- CVE-2022-1811 Unrestricted Upload of File with Dangerous Type in publify/publify
- CVE-2022-1553 Leaking password protected articles content due to improper access control in publify/publify
- CVE-2023-0299 Improper Input Validation in publify/publify
- CVE-2023-0569 Weak Password Requirements in publify/publify
Sources
Also known as BIT-publify-2021-25973, GHSA-x24j-87x9-jvv5.