# CVE-2021-25973: Publify - Improper Authorization Leads to Guest Signup Restriction Bypass

> Attackers can bypass guest signup restrictions in Publify due to improper authorization checks, allowing unauthorized user registration.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Nov 2021
- **Updated:** 30 Apr 2025
- **Also known as:** BIT-publify-2021-25973, GHSA-x24j-87x9-jvv5

## What is CVE-2021-25973?

CVE-2021-25973 is a medium-severity missing authorization vulnerability in publify_core, published on 2 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Publify, 9.0.0.pre1 to 9.2.4 are vulnerable to Improper Access Control. “guest” role users can self-register even when the admin does not allow. This happens due to front-end restriction only.

Weakness: CWE-669 (Incorrect Resource Transfer Between Spheres), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2021-25973?

3 open source packages ship an affected version, including publify_core and publify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `publify_core` | RubyGems | From 9.0.0.pre1 | 9.2.5 |
| `publify_core` | RubyGems | From 9.0.0.pre1 | 9.2.5 |
| `publify` | Bitnami | From 9.0.0 | 9.2.4 |

Products: Publify Project Publify.

## How do I fix CVE-2021-25973?

Upgrade publify_core to 9.2.5 or later.

## Is CVE-2021-25973 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25973 exists.

## Other vulnerabilities in publify_core

- [CVE-2022-1810](https://insights.sbomify.com/CVE-2022-1810/): Authorization Bypass Through User-Controlled Key in publify/publify (critical 9.9)
- [CVE-2022-1811](https://insights.sbomify.com/CVE-2022-1811/): Unrestricted Upload of File with Dangerous Type in publify/publify (critical 9.1)
- [CVE-2022-1553](https://insights.sbomify.com/CVE-2022-1553/): Leaking password protected articles content due to improper access control in publify/publify (high 8.8)
- [CVE-2023-0299](https://insights.sbomify.com/CVE-2023-0299/): Improper Input Validation in publify/publify (high 8.4)
- [CVE-2023-0569](https://insights.sbomify.com/CVE-2023-0569/): Weak Password Requirements in publify/publify (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-25973 and fix it if it is affected.

What it is: CVE-2021-25973 is a medium-severity missing authorization vulnerability in publify_core, published on 2 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25973 exists.

Affected packages and fixed versions:
- publify_core (RubyGems): affected from 9.0.0.pre1; fixed in 9.2.5
- publify_core (RubyGems): affected from 9.0.0.pre1; fixed in 9.2.5
- publify (Bitnami): affected from 9.0.0; fixed in 9.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-25973/ (Markdown: https://insights.sbomify.com/CVE-2021-25973/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-25973
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-25973
- OSV: https://osv.dev/vulnerability/CVE-2021-25973

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-25973/
Summaries are generated and may contain mistakes; the official description above is the record.
