CVE-2021-25974 Publify - Stored Cross-Site Scripting (XSS) in Editor

Medium 5.4 Published Updated

A publisher can inject arbitrary JavaScript into pages or articles, potentially leading to code execution or account takeover.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-25974?

CVE-2021-25974 is a medium-severity cross-site scripting vulnerability in publify_core, published on 10 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

In Publify, versions v8.0 to v9.2.4 are vulnerable to stored XSS. A user with a “publisher” role is able to inject and execute arbitrary JavaScript code while creating a page/article.

Weakness: CWE-79

Which versions are affected by CVE-2021-25974?

3 open source packages ship an affected version, including publify_core and publify. It affects 1 product.

PackageAffectedFixed in
publify_core RubyGemsFrom 8.09.2.5
publify_core RubyGemsFrom 8.09.2.5
publify BitnamiFrom 8.0.09.2.4

Products include Publify Project Publify.

How do I fix CVE-2021-25974?

Upgrade publify_core to 9.2.5 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-25974 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25974 exists.

Sources

Also known as BIT-publify-2021-25974, GHSA-wmh9-x28j-c6gr.

Is CVE-2021-25974 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free