{"answers":{"affected":"2 open source packages ship an affected version, including apostrophe. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-25978 in the wild and no public exploit code.","fix":"Upgrade apostrophe to 3.4.0 or later.","what":"CVE-2021-25978 is a medium-severity cross-site scripting vulnerability in Apostrophe , published on 7 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-25978 and fix it if it is affected.\n\nWhat it is: CVE-2021-25978 is a medium-severity cross-site scripting vulnerability in Apostrophe , published on 7 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-25978 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apostrophe (npm): affected from 2.63.0; fixed in 3.4.0\n- apostrophe (npm): affected from 2.63.0; fixed in 3.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-25978/ (Markdown: https://insights.sbomify.com/CVE-2021-25978/index.md)","id":"CVE-2021-25978","markdown":"https://insights.sbomify.com/CVE-2021-25978/index.md","name":"CVE-2021-25978","record":{"aliases":["GHSA-4r9c-jghc-cx5m"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Apostrophe CMS","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary JavaScript in victim browsers by uploading malicious SVG files to the Apostrophe CMS Images module.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mend","cpe":[{"product":"apostrophecms","vendor":"apostrophecms"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Apostrophe CMS versions between 2.63.0 to 3.3.1 are vulnerable to Stored XSS where an editor uploads an SVG file that contains malicious JavaScript onto the Images module, which triggers XSS once viewed.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apostrophe - XSS","id":"CVE-2021-25978","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":1,"next":{"headline":"Apostrophe - Insufficient Session Expiration","id":"CVE-2021-25979"},"packages":[{"ecosystem":"npm","fixed":["3.4.0"],"introduced":["2.63.0"],"last_affected":[],"package":"apostrophe","purl":null,"source":"GHSA-4r9c-jghc-cx5m"},{"ecosystem":"npm","fixed":["3.4.0"],"introduced":["2.63.0"],"last_affected":[],"package":"apostrophe","purl":"pkg:npm/apostrophe","source":"GHSA-4r9c-jghc-cx5m"}],"prev":{"headline":"Piranha CMS - Stored XSS in Page Title","id":"CVE-2021-25977"},"products":["Apostrophe "],"published":"2021-11-07","related":[{"cvss_score":9.8,"headline":"Apostrophe - Insufficient Session Expiration","id":"CVE-2021-25979","kev_date_added":null,"published":"2021-11-08"},{"cvss_score":8.7,"headline":"ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS","id":"CVE-2026-35569","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":8.1,"headline":"ApostropheCMS MFA/TOTP Bypass via Incorrect MongoDB Query in Bearer Token Middleware","id":"CVE-2026-32730","kev_date_added":null,"published":"2026-03-18"},{"cvss_score":6.1,"headline":"ApostropheCMS: sanitize-html allowedTags Bypass via Entity-Decoded Text in nonTextTags Elements","id":"CVE-2026-40186","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":5.4,"headline":"ApostropheCMS: Stored XSS via CSS Custom Property Injection in `@apostrophecms/color-field` Escaping Style Tag Context","id":"CVE-2026-33889","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":5.3,"headline":"ApostropheCMS: publicApiProjection Bypass via `project` Query Builder in Piece-Type REST API","id":"CVE-2026-33888","kev_date_added":null,"published":"2026-04-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-30","vendors":["Apostrophe "]},"summary":"Attackers can execute arbitrary JavaScript in victim browsers by uploading malicious SVG files to the Apostrophe CMS Images module.","url":"https://insights.sbomify.com/CVE-2021-25978/"}