{"answers":{"affected":"2 open source packages ship an affected version, including apostrophe. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-25979 in the wild and no public exploit code.","fix":"Upgrade apostrophe to 3.4.0 or later.","what":"CVE-2021-25979 is a critical vulnerability in Apostrophe , published on 8 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-25979 and fix it if it is affected.\n\nWhat it is: CVE-2021-25979 is a critical vulnerability in Apostrophe , published on 8 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-25979 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apostrophe (npm): affected from 2.63.0; fixed in 3.4.0\n- apostrophe (npm): affected from 2.63.0; fixed in 3.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-25979/ (Markdown: https://insights.sbomify.com/CVE-2021-25979/index.md)","id":"CVE-2021-25979","markdown":"https://insights.sbomify.com/CVE-2021-25979/index.md","name":"CVE-2021-25979","record":{"aliases":["GHSA-9j9m-8wjc-ff96"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apostrophe CMS","requires_auth":"none","summary":"Attackers can maintain access via compromised devices because disabling accounts or changing passwords does not invalidate existing sessions in Apostrophe CMS.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mend","cpe":[{"product":"apostrophecms","vendor":"apostrophecms"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"Apostrophe CMS versions prior to 3.3.1 did not invalidate existing login sessions when disabling a user account or changing the password, creating a situation in which a device compromised by a third party could not be locked out by those means. As a mitigation for older releases the user account in question can be archived (3.x) or moved to the trash (2.x and earlier) which does disable the existing session.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apostrophe - Insufficient Session Expiration","id":"CVE-2021-25979","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2021"},"n_packages":2,"n_references":1,"next":{"headline":"Talkyard - Host-Header Injection Leads to Account Takeover","id":"CVE-2021-25980"},"packages":[{"ecosystem":"npm","fixed":["3.4.0"],"introduced":["2.63.0"],"last_affected":[],"package":"apostrophe","purl":null,"source":"GHSA-9j9m-8wjc-ff96"},{"ecosystem":"npm","fixed":["3.4.0"],"introduced":["2.63.0"],"last_affected":[],"package":"apostrophe","purl":"pkg:npm/apostrophe","source":"GHSA-9j9m-8wjc-ff96"}],"prev":{"headline":"Apostrophe - XSS","id":"CVE-2021-25978"},"products":["Apostrophe "],"published":"2021-11-08","related":[{"cvss_score":8.7,"headline":"ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS","id":"CVE-2026-35569","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":8.1,"headline":"ApostropheCMS MFA/TOTP Bypass via Incorrect MongoDB Query in Bearer Token Middleware","id":"CVE-2026-32730","kev_date_added":null,"published":"2026-03-18"},{"cvss_score":6.1,"headline":"ApostropheCMS: sanitize-html allowedTags Bypass via Entity-Decoded Text in nonTextTags Elements","id":"CVE-2026-40186","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":5.4,"headline":"ApostropheCMS: Stored XSS via CSS Custom Property Injection in `@apostrophecms/color-field` Escaping Style Tag Context","id":"CVE-2026-33889","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":5.4,"headline":"Apostrophe - XSS","id":"CVE-2021-25978","kev_date_added":null,"published":"2021-11-07"},{"cvss_score":5.3,"headline":"ApostropheCMS: publicApiProjection Bypass via `project` Query Builder in Piece-Type REST API","id":"CVE-2026-33888","kev_date_added":null,"published":"2026-04-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-30","vendors":["Apostrophe "]},"summary":"Attackers can maintain access via compromised devices because disabling accounts or changing passwords does not invalidate existing sessions in Apostrophe CMS.","url":"https://insights.sbomify.com/CVE-2021-25979/"}