CVE-2021-25986 Django-wiki - Stored Cross-Site Scripting (XSS) in Notifications Section
An attacker with edit access can inject JavaScript into page titles, leading to stored XSS execution in the victim's notification panel.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-25986?
CVE-2021-25986 is a medium-severity cross-site scripting vulnerability in Django-wiki, published on 23 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
In Django-wiki, versions 0.0.20 to 0.7.8 are vulnerable to Stored Cross-Site Scripting (XSS) in Notifications Section. An attacker who has access to edit pages can inject JavaScript payload in the title field. When a victim gets a notification regarding the changes made in the application, the payload in the notification panel renders and loads external JavaScript.
Weakness: CWE-79
Which versions are affected by CVE-2021-25986?
3 open source packages ship an affected version, including wiki. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
wiki PyPI | From 0.0.20 | 0.7.9 |
wiki PyPI | From 0.0.20 | 0.7.9 |
wiki PyPI | From 0.0.20 | 0.7.9 |
Products include Django-Wiki Project Django-Wiki.
How do I fix CVE-2021-25986?
Upgrade wiki to 0.7.9 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-25986 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25986 exists.
Other vulnerabilities in Django-wiki
Sources
Also known as GHSA-3m3h-v9hv-9j4h, PYSEC-2021-850.