# CVE-2021-25986: Django-wiki - Stored Cross-Site Scripting (XSS) in Notifications Section

> An attacker with edit access can inject JavaScript into page titles, leading to stored XSS execution in the victim's notification panel.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Nov 2021
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-3m3h-v9hv-9j4h, PYSEC-2021-850

## What is CVE-2021-25986?

CVE-2021-25986 is a medium-severity cross-site scripting vulnerability in Django-wiki, published on 23 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Django-wiki, versions 0.0.20 to 0.7.8 are vulnerable to Stored Cross-Site Scripting (XSS) in Notifications Section. An attacker who has access to edit pages can inject JavaScript payload in the title field. When a victim gets a notification regarding the changes made in the application, the payload in the notification panel renders and loads external JavaScript.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-25986?

3 open source packages ship an affected version, including wiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wiki` | PyPI | From 0.0.20 | 0.7.9 |
| `wiki` | PyPI | From 0.0.20 | 0.7.9 |
| `wiki` | PyPI | From 0.0.20 | 0.7.9 |

Products: Django-Wiki Project Django-Wiki.

## How do I fix CVE-2021-25986?

Upgrade wiki to 0.7.9 or later.

## Is CVE-2021-25986 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25986 exists.

## Other vulnerabilities in Django-wiki

- [CVE-2024-28865](https://insights.sbomify.com/CVE-2024-28865/): django-wiki denial of service via regular expression (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-25986 and fix it if it is affected.

What it is: CVE-2021-25986 is a medium-severity cross-site scripting vulnerability in Django-wiki, published on 23 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25986 exists.

Affected packages and fixed versions:
- wiki (PyPI): affected from 0.0.20; fixed in 0.7.9
- wiki (PyPI): affected from 0.0.20; fixed in 0.7.9
- wiki (PyPI): affected from 0.0.20; fixed in 0.7.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-25986/ (Markdown: https://insights.sbomify.com/CVE-2021-25986/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-25986
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-25986
- OSV: https://osv.dev/vulnerability/CVE-2021-25986

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-25986/
Summaries are generated and may contain mistakes; the official description above is the record.
