# CVE-2021-26073: Broken Authentication in Atlassian Connect Express

> An attacker can bypass authentication in Atlassian Connect Express by sending context JWTs to lifecycle endpoints, allowing unauthorized re-installation events.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2021
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-4v96-m8xv-x83v

## What is CVE-2021-26073?

CVE-2021-26073 is a high-severity authentication bypass vulnerability in Atlassian Connect Express (ACE), published on 16 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Broken Authentication in Atlassian Connect Express (ACE) from version 3.0.2 before version 6.6.0: Atlassian Connect Express is a Node.js package for building Atlassian Connect apps. Authentication between Atlassian products and the Atlassian Connect Express app occurs with a server-to-server JWT or a context JWT. Atlassian Connect Express versions from 3.0.2 before 6.6.0 erroneously accept context JWTs in lifecycle endpoints (such as installation) where only server-to-server JWTs should be accepted, permitting an attacker to send authenticated re-installation events to an app.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2021-26073?

2 open source packages ship an affected version, including atlassian-connect-express. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `atlassian-connect-express` | npm | From 3.0.2 | 6.6.0 |
| `atlassian-connect-express` | npm | From 3.0.2 | 6.6.0 |

Products: Atlassian Connect Express.

## How do I fix CVE-2021-26073?

Upgrade atlassian-connect-express to 6.6.0 or later.

## Is CVE-2021-26073 being exploited?

There is no known exploitation of CVE-2021-26073 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-26073 and fix it if it is affected.

What it is: CVE-2021-26073 is a high-severity authentication bypass vulnerability in Atlassian Connect Express (ACE), published on 16 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-26073 in the wild and no public exploit code.

Affected packages and fixed versions:
- atlassian-connect-express (npm): affected from 3.0.2; fixed in 6.6.0
- atlassian-connect-express (npm): affected from 3.0.2; fixed in 6.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-26073/ (Markdown: https://insights.sbomify.com/CVE-2021-26073/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-26073
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-26073
- OSV: https://osv.dev/vulnerability/CVE-2021-26073

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-26073/
Summaries are generated and may contain mistakes; the official description above is the record.
