# CVE-2021-26077: Improper Authentication in Atlassian Connect Spring Boot

> An attacker can bypass authentication in Atlassian Connect Spring Boot by sending context JWTs to lifecycle endpoints, allowing unauthorized re-installation events.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2021
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-2x7v-w2mv-f3rx

## What is CVE-2021-26077?

CVE-2021-26077 is a critical authentication bypass vulnerability in Atlassian Connect Spring Boot (ACSB), published on 9 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Broken Authentication in Atlassian Connect Spring Boot (ACSB) in version 1.1.0 before 2.1.3 and from version 2.1.4 before 2.1.5: Atlassian Connect Spring Boot is a Java Spring Boot package for building Atlassian Connect apps. Authentication between Atlassian products and the Atlassian Connect Spring Boot app occurs with a server-to-server JWT or a context JWT. Atlassian Connect Spring Boot versions 1.1.0 before 2.1.3 and versions 2.1.4 before 2.1.5 erroneously accept context JWTs in lifecycle endpoints (such as installation) where only server-to-server JWTs should be accepted, permitting an attacker to send authenticated re-installation events to an app.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2021-26077?

4 open source packages ship an affected version, including com.atlassian.connect:atlassian-connect-spring-boot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.atlassian.connect:atlassian-connect-spring-boot` | Maven | From 1.1.0 | 2.1.3 |
| `com.atlassian.connect:atlassian-connect-spring-boot` | Maven | From 1.1.0 | 2.1.3 |
| `com.atlassian.connect:atlassian-connect-spring-boot` | Maven | From 2.1.4 | 2.1.5 |
| `com.atlassian.connect:atlassian-connect-spring-boot` | Maven | From 2.1.4 | 2.1.5 |

Products: Atlassian Connect Spring Boot.

## How do I fix CVE-2021-26077?

Upgrade com.atlassian.connect:atlassian-connect-spring-boot to a fixed version for your release line: 2.1.3 or 2.1.5.

## Is CVE-2021-26077 being exploited?

There is no known exploitation of CVE-2021-26077 in the wild and no public exploit code.

## Other vulnerabilities in Atlassian Connect Spring Boot (ACSB)

- [CVE-2021-26074](https://insights.sbomify.com/CVE-2021-26074/): Broken Authentication in Atlassian Connect Spring Boot (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-26077 and fix it if it is affected.

What it is: CVE-2021-26077 is a critical authentication bypass vulnerability in Atlassian Connect Spring Boot (ACSB), published on 9 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-26077 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.atlassian.connect:atlassian-connect-spring-boot (Maven): affected from 1.1.0; fixed in 2.1.3
- com.atlassian.connect:atlassian-connect-spring-boot (Maven): affected from 1.1.0; fixed in 2.1.3
- com.atlassian.connect:atlassian-connect-spring-boot (Maven): affected from 2.1.4; fixed in 2.1.5
- com.atlassian.connect:atlassian-connect-spring-boot (Maven): affected from 2.1.4; fixed in 2.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-26077/ (Markdown: https://insights.sbomify.com/CVE-2021-26077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-26077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-26077
- OSV: https://osv.dev/vulnerability/CVE-2021-26077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-26077/
Summaries are generated and may contain mistakes; the official description above is the record.
