CVE-2021-26117 ActiveMQ: LDAP-Authentication does not verify passwords on servers with anonymous bind
Attackers can bypass authentication in Apache ActiveMQ when the optional LDAP login module is configured for anonymous access, allowing unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-26117?
CVE-2021-26117 is a high-severity authentication bypass vulnerability in Apache Activemq, published on 27 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The optional ActiveMQ LDAP login module can be configured to use anonymous access to the LDAP server. In this case, for Apache ActiveMQ Artemis prior to version 2.16.0 and Apache ActiveMQ prior to versions 5.16.1 and 5.15.14, the anonymous context is used to verify a valid users password in error, resulting in no check on the password.
Weakness: CWE-287
Which versions are affected by CVE-2021-26117?
7 open source packages ship an affected version, including org.apache.activemq:activemq-parent, activemq and org.apache.activemq:apache-artemis. It affects 8 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.activemq:activemq-parent Maven | All versions | 5.15.14 |
org.apache.activemq:activemq-parent Maven | All versions | 5.15.14 |
org.apache.activemq:activemq-parent Maven | From 5.16.0 | 5.16.1 |
org.apache.activemq:activemq-parent Maven | From 5.16.0 | 5.16.1 |
activemq Bitnami | From 5.15.0 | 5.15.14, 5.16.1 |
org.apache.activemq:apache-artemis Maven | All versions | 2.16.0 |
1 more packages
org.apache.activemq:apache-artemis Maven | All versions | 2.16.0 |
Products include Apache Activemq, Apache Artemis, Debian Debian Linux, Netapp Oncommand Workflow Automation, Oracle Communications Element Manager, Oracle Communications Session Report Manager and 2 more.
How do I fix CVE-2021-26117?
Upgrade org.apache.activemq:activemq-parent to a fixed version for your release line: 5.15.14 or 5.16.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2021-26117 being exploited?
There is no known exploitation of CVE-2021-26117 in the wild and no public exploit code.
Other vulnerabilities in Apache Activemq
Sources
Also known as BIT-activemq-2021-26117, DEBIAN-CVE-2021-26117, GHSA-9mgm-gcq8-86wq, UBUNTU-CVE-2021-26117.