# CVE-2021-26117: ActiveMQ: LDAP-Authentication does not verify passwords on servers with anonymous bind

> Attackers can bypass authentication in Apache ActiveMQ when the optional LDAP login module is configured for anonymous access, allowing unauthorized access.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-activemq-2021-26117, DEBIAN-CVE-2021-26117, GHSA-9mgm-gcq8-86wq, UBUNTU-CVE-2021-26117

## What is CVE-2021-26117?

CVE-2021-26117 is a high-severity authentication bypass vulnerability in Apache Activemq, published on 27 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The optional ActiveMQ LDAP login module can be configured to use anonymous access to the LDAP server. In this case, for Apache ActiveMQ Artemis prior to version 2.16.0 and Apache ActiveMQ prior to versions 5.16.1 and 5.15.14, the anonymous context is used to verify a valid users password in error, resulting in no check on the password.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2021-26117?

7 open source packages ship an affected version, including org.apache.activemq:activemq-parent, activemq and org.apache.activemq:apache-artemis. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-parent` | Maven | All versions | 5.15.14 |
| `org.apache.activemq:activemq-parent` | Maven | All versions | 5.15.14 |
| `org.apache.activemq:activemq-parent` | Maven | From 5.16.0 | 5.16.1 |
| `org.apache.activemq:activemq-parent` | Maven | From 5.16.0 | 5.16.1 |
| `activemq` | Bitnami | From 5.15.0 | 5.15.14, 5.16.1 |
| `org.apache.activemq:apache-artemis` | Maven | All versions | 2.16.0 |
| `org.apache.activemq:apache-artemis` | Maven | All versions | 2.16.0 |

Products: Apache Activemq, Apache Artemis, Debian Debian Linux, Netapp Oncommand Workflow Automation, Oracle Communications Element Manager, Oracle Communications Session Report Manager, Oracle Communications Session Route Manager, Oracle Flexcube Private Banking.

## How do I fix CVE-2021-26117?

Upgrade org.apache.activemq:activemq-parent to a fixed version for your release line: 5.15.14 or 5.16.1.

## Is CVE-2021-26117 being exploited?

There is no known exploitation of CVE-2021-26117 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-26117 and fix it if it is affected.

What it is: CVE-2021-26117 is a high-severity authentication bypass vulnerability in Apache Activemq, published on 27 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-26117 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-parent (Maven): affected all versions; fixed in 5.15.14
- org.apache.activemq:activemq-parent (Maven): affected all versions; fixed in 5.15.14
- org.apache.activemq:activemq-parent (Maven): affected from 5.16.0; fixed in 5.16.1
- org.apache.activemq:activemq-parent (Maven): affected from 5.16.0; fixed in 5.16.1
- activemq (Bitnami): affected from 5.15.0; fixed in 5.15.14, 5.16.1
- org.apache.activemq:apache-artemis (Maven): affected all versions; fixed in 2.16.0
- org.apache.activemq:apache-artemis (Maven): affected all versions; fixed in 2.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-26117/ (Markdown: https://insights.sbomify.com/CVE-2021-26117/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-26117
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-26117
- OSV: https://osv.dev/vulnerability/CVE-2021-26117

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-26117/
Summaries are generated and may contain mistakes; the official description above is the record.
