CVE-2021-26263 Cross-site scripting in Odoo Community
Remote attackers can inject arbitrary web script into victims' browsers via the Discuss app in Odoo Community and Enterprise.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-26263?
CVE-2021-26263 is a high-severity cross-site scripting vulnerability in Odoo Odoo, published on 25 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Cross-site scripting (XSS) issue in Discuss app of Odoo Community 14.0 through 15.0, and Odoo Enterprise 14.0 through 15.0, allows remote attackers to inject arbitrary web script in the browser of a victim, by posting crafted contents.
Weakness: CWE-79
Which versions are affected by CVE-2021-26263?
1 open source package ship an affected version, including odoo. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
odoo Bitnami | From 14.0.0 | 14.0.1, 15.0.1 |
Products include Odoo Odoo.
How do I fix CVE-2021-26263?
Upgrade odoo to a fixed version for your release line: 14.0.1 or 15.0.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-26263 being exploited?
There is no known exploitation of CVE-2021-26263 in the wild and no public exploit code.
Other vulnerabilities in Odoo Odoo
Sources
Also known as BIT-odoo-2021-26263, DEBIAN-CVE-2021-26263, GHSA-mhqq-4cm6-w4w2, UBUNTU-CVE-2021-26263.