# CVE-2021-26263: Cross-site scripting in Odoo Community

> Remote attackers can inject arbitrary web script into victims' browsers via the Discuss app in Odoo Community and Enterprise.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2023
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-odoo-2021-26263, DEBIAN-CVE-2021-26263, GHSA-mhqq-4cm6-w4w2, UBUNTU-CVE-2021-26263

## What is CVE-2021-26263?

CVE-2021-26263 is a high-severity cross-site scripting vulnerability in Odoo Odoo, published on 25 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cross-site scripting (XSS) issue in Discuss app of Odoo Community 14.0 through 15.0, and Odoo Enterprise 14.0 through 15.0, allows remote attackers to inject arbitrary web script in the browser of a victim, by posting crafted contents.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-26263?

1 open source package ship an affected version, including odoo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `odoo` | Bitnami | From 14.0.0 | 14.0.1, 15.0.1 |

Products: Odoo Odoo.

## How do I fix CVE-2021-26263?

Upgrade odoo to a fixed version for your release line: 14.0.1 or 15.0.1.

## Is CVE-2021-26263 being exploited?

There is no known exploitation of CVE-2021-26263 in the wild and no public exploit code.

## Other vulnerabilities in Odoo Odoo

- [CVE-2020-29396](https://insights.sbomify.com/CVE-2020-29396/): Code injection in Odoo Community (critical 9.9)
- [CVE-2018-14885](https://insights.sbomify.com/CVE-2018-14885/): Auth bypass in n/a (critical 9.8)
- [CVE-2017-10804](https://insights.sbomify.com/CVE-2017-10804/): Auth bypass in n/a (critical 9.8)
- [CVE-2018-14860](https://insights.sbomify.com/CVE-2018-14860/): Code injection in n/a (critical 9.1)
- [CVE-2017-10805](https://insights.sbomify.com/CVE-2017-10805/): Auth bypass in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-26263 and fix it if it is affected.

What it is: CVE-2021-26263 is a high-severity cross-site scripting vulnerability in Odoo Odoo, published on 25 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-26263 in the wild and no public exploit code.

Affected packages and fixed versions:
- odoo (Bitnami): affected from 14.0.0; fixed in 14.0.1, 15.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-26263/ (Markdown: https://insights.sbomify.com/CVE-2021-26263/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-26263
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-26263
- OSV: https://osv.dev/vulnerability/CVE-2021-26263

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-26263/
Summaries are generated and may contain mistakes; the official description above is the record.
