# CVE-2021-26276: Improper Control of Dynamically-Managed Code Resources in config-shield

> Attacker can execute arbitrary code via eval in the set command if untrusted data is processed, affecting GoDaddy node-config-shield users.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2021
- **Updated:** 19 Nov 2024
- **Also known as:** GHSA-w8h4-vw8f-rvvj

## What is CVE-2021-26276?

CVE-2021-26276 is a medium-severity code injection vulnerability in n/a, published on 27 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

scripts/cli.js in the GoDaddy node-config-shield (aka Config Shield) package before 0.2.2 for Node.js calls eval when processing a set command. NOTE: the vendor reportedly states that this is not a vulnerability. The set command was not intended for use with untrusted data

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources)

## Which versions are affected by CVE-2021-26276?

2 open source packages ship an affected version, including config-shield. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `config-shield` | npm | All versions | 0.2.3 |
| `config-shield` | npm | All versions | 0.2.3 |

Products: Godaddy Node-Config-Shield.

## How do I fix CVE-2021-26276?

Upgrade config-shield to 0.2.3 or later.

## Is CVE-2021-26276 being exploited?

There is no known exploitation of CVE-2021-26276 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-26276 and fix it if it is affected.

What it is: CVE-2021-26276 is a medium-severity code injection vulnerability in n/a, published on 27 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-26276 in the wild and no public exploit code.

Affected packages and fixed versions:
- config-shield (npm): affected all versions; fixed in 0.2.3
- config-shield (npm): affected all versions; fixed in 0.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-26276/ (Markdown: https://insights.sbomify.com/CVE-2021-26276/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-26276
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-26276
- OSV: https://osv.dev/vulnerability/CVE-2021-26276

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-26276/
Summaries are generated and may contain mistakes; the official description above is the record.
