# CVE-2021-26305: Read of uninitialized memory in cdr

> A flaw in the Rust cdr crate allows attackers to read uninitialized heap memory, potentially exposing sensitive data.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-37jj-wp7g-7wj4, RUSTSEC-2021-0012

## What is CVE-2021-26305?

CVE-2021-26305 is a critical vulnerability in n/a, published on 29 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Deserializer::read_vec in the cdr crate before 0.2.4 for Rust. A user-provided Read implementation can gain access to the old contents of newly allocated heap memory, violating soundness.

Weakness: CWE-908 (Use of Uninitialized Resource)

## Which versions are affected by CVE-2021-26305?

3 open source packages ship an affected version, including cdr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cdr` | crates.io | All versions | 0.2.4 |
| `cdr` | crates.io | All versions | 0.2.4 |
| `cdr` | crates.io | From 0.0.0-0 | 0.2.4 |

Products: Cdr Project Cdr.

## How do I fix CVE-2021-26305?

Upgrade cdr to 0.2.4 or later.

## Is CVE-2021-26305 being exploited?

There is no known exploitation of CVE-2021-26305 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-26305 and fix it if it is affected.

What it is: CVE-2021-26305 is a critical vulnerability in n/a, published on 29 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-26305 in the wild and no public exploit code.

Affected packages and fixed versions:
- cdr (crates.io): affected all versions; fixed in 0.2.4
- cdr (crates.io): affected all versions; fixed in 0.2.4
- cdr (crates.io): affected from 0.0.0-0; fixed in 0.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-26305/ (Markdown: https://insights.sbomify.com/CVE-2021-26305/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-26305
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-26305
- OSV: https://osv.dev/vulnerability/CVE-2021-26305

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-26305/
Summaries are generated and may contain mistakes; the official description above is the record.
