# CVE-2021-26306: Soundness issue in raw-cpuid

> Unsound transmute calls in the raw-cpuid crate allow attackers to trigger memory corruption, potentially leading to arbitrary code execution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hvqc-pc78-x9wh

## What is CVE-2021-26306?

CVE-2021-26306 is a high-severity memory corruption vulnerability in n/a, published on 29 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the raw-cpuid crate before 9.0.0 for Rust. It has unsound transmute calls within as_string() methods.

## Which versions are affected by CVE-2021-26306?

2 open source packages ship an affected version, including raw-cpuid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `raw-cpuid` | crates.io | All versions | 9.0.0 |
| `raw-cpuid` | crates.io | All versions | 9.0.0 |

Products: Raw-Cpuid Project Raw-Cpuid.

## How do I fix CVE-2021-26306?

Upgrade raw-cpuid to 9.0.0 or later.

## Is CVE-2021-26306 being exploited?

There is no known exploitation of CVE-2021-26306 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-45687](https://insights.sbomify.com/CVE-2021-45687/): Optional `Deserialize` implementations lacking validation (critical 9.8)
- [CVE-2021-26307](https://insights.sbomify.com/CVE-2021-26307/): Error on unsupported architectures in raw-cpuid (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-26306 and fix it if it is affected.

What it is: CVE-2021-26306 is a high-severity memory corruption vulnerability in n/a, published on 29 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-26306 in the wild and no public exploit code.

Affected packages and fixed versions:
- raw-cpuid (crates.io): affected all versions; fixed in 9.0.0
- raw-cpuid (crates.io): affected all versions; fixed in 9.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-26306/ (Markdown: https://insights.sbomify.com/CVE-2021-26306/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-26306
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-26306
- OSV: https://osv.dev/vulnerability/CVE-2021-26306

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-26306/
Summaries are generated and may contain mistakes; the official description above is the record.
