# CVE-2021-26505: MrSwitch hello.js vulnerable to prototype pollution


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 11 Aug 2023
- **Updated:** 9 Oct 2024
- **Also known as:** GHSA-g3vf-47fv-8f3c

## What is CVE-2021-26505?

CVE-2021-26505 is a critical vulnerability in n/a, published on 11 Aug 2023. 

### Official description

Prototype pollution vulnerability in MrSwitch hello.js version 1.18.6, allows remote attackers to execute arbitrary code via hello.utils.extend function.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2021-26505?

2 open source packages ship an affected version, including hellojs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hellojs` | npm | All versions | 1.18.8 |
| `hellojs` | npm | All versions | 1.18.8 |

Products: Hello.js Project Hello.js.

## How do I fix CVE-2021-26505?

Upgrade hellojs to 1.18.8 or later.

## Is CVE-2021-26505 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-26505 exists.

## Other vulnerabilities in n/a

- [CVE-2020-7741](https://insights.sbomify.com/CVE-2020-7741/): Cross-site Scripting (XSS) (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-26505 and fix it if it is affected.

What it is: CVE-2021-26505 is a critical vulnerability in n/a, published on 11 Aug 2023. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-26505 exists.

Affected packages and fixed versions:
- hellojs (npm): affected all versions; fixed in 1.18.8
- hellojs (npm): affected all versions; fixed in 1.18.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-26505/ (Markdown: https://insights.sbomify.com/CVE-2021-26505/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-26505
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-26505
- OSV: https://osv.dev/vulnerability/CVE-2021-26505

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-26505/
Summaries are generated and may contain mistakes; the official description above is the record.
