{"answers":{"affected":"2 open source packages ship an affected version, including git-parse. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-26543 in the wild and no public exploit code.","fix":"Upgrade git-parse to 1.0.5 or later.","what":"CVE-2021-26543 is a high-severity command injection vulnerability in n/a, published on 6 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-26543 and fix it if it is affected.\n\nWhat it is: CVE-2021-26543 is a high-severity command injection vulnerability in n/a, published on 6 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-26543 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- git-parse (npm): affected all versions; fixed in 1.0.5\n- git-parse (npm): affected all versions; fixed in 1.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-26543/ (Markdown: https://insights.sbomify.com/CVE-2021-26543/index.md)","id":"CVE-2021-26543","markdown":"https://insights.sbomify.com/CVE-2021-26543/index.md","name":"CVE-2021-26543","record":{"aliases":["GHSA-m744-2jj8-vpfv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js git parsing library","requires_auth":"none","summary":"The git-parse library allows command injection via the gitDiff function, enabling attackers to execute arbitrary commands on systems using this npm package.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"git-parse","vendor":"wayfair"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"The \"gitDiff\" function in Wayfair git-parse \u003c=1.0.4 has a command injection vulnerability. Clients of the git-parse library are unlikely to be aware of this, so they might unwittingly write code that contains a vulnerability. The issue has been resolved in version 1.0.5.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command injection in git-parse","id":"CVE-2021-26543","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Apache Livy (Incubating) is vulnerable to cross site scripting","id":"CVE-2021-26544"},"packages":[{"ecosystem":"npm","fixed":["1.0.5"],"introduced":["0"],"last_affected":[],"package":"git-parse","purl":null,"source":"GHSA-m744-2jj8-vpfv"},{"ecosystem":"npm","fixed":["1.0.5"],"introduced":["0"],"last_affected":[],"package":"git-parse","purl":"pkg:npm/git-parse","source":"GHSA-m744-2jj8-vpfv"}],"prev":{"headline":"Command injection in gitlog","id":"CVE-2021-26541"},"products":["n/a"],"published":"2021-05-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"The git-parse library allows command injection via the gitDiff function, enabling attackers to execute arbitrary commands on systems using this npm package.","url":"https://insights.sbomify.com/CVE-2021-26543/"}