{"answers":{"affected":"2 open source packages ship an affected version, including impresscms/impresscms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-26600 in the wild and no public exploit code.","fix":"Upgrade impresscms/impresscms to 1.4.3 or later.","what":"CVE-2021-26600 is a critical authentication bypass vulnerability in n/a, published on 28 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-26600 and fix it if it is affected.\n\nWhat it is: CVE-2021-26600 is a critical authentication bypass vulnerability in n/a, published on 28 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-26600 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- impresscms/impresscms (Packagist): affected all versions; fixed in 1.4.3\n- impresscms/impresscms (Packagist): affected all versions; fixed in 1.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-26600/ (Markdown: https://insights.sbomify.com/CVE-2021-26600/index.md)","id":"CVE-2021-26600","markdown":"https://insights.sbomify.com/CVE-2021-26600/index.md","name":"CVE-2021-26600","record":{"aliases":["GHSA-m8xh-cqc2-5q6f"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"ImpressCMS","requires_auth":"none","summary":"Attackers can bypass authentication in ImpressCMS due to a type confusion vulnerability in the autologin plugin.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"impresscms","vendor":"impresscms"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-843","name":"Access of Resource Using Incompatible Type"}],"description":"ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant Authentication Bypass (!= instead of !==).","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Type Confusion in ImpressCMS","id":"CVE-2021-26600","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"Path Traversal in ImpressCMS","id":"CVE-2021-26601"},"packages":[{"ecosystem":"Packagist","fixed":["1.4.3"],"introduced":["0"],"last_affected":[],"package":"impresscms/impresscms","purl":null,"source":"GHSA-m8xh-cqc2-5q6f"},{"ecosystem":"Packagist","fixed":["1.4.3"],"introduced":["0"],"last_affected":[],"package":"impresscms/impresscms","purl":"pkg:composer/impresscms/impresscms","source":"GHSA-m8xh-cqc2-5q6f"}],"prev":{"headline":"SQL Injection in ImpressCMS","id":"CVE-2021-26599"},"products":["n/a"],"published":"2022-03-28","related":[{"cvss_score":10,"headline":"Multiple unspecified vulnerabilities in ImpressCMS 1.0 have unknown impact and attack vectors, related to modules/admin.php and \"a few files","id":"CVE-2008-3453","kev_date_added":null,"published":"2008-08-04"},{"cvss_score":9.8,"headline":"SQL Injection in ImpressCMS","id":"CVE-2021-26599","kev_date_added":null,"published":"2022-03-28"},{"cvss_score":9.8,"headline":"Path Traversal in ImpressCMS","id":"CVE-2022-24977","kev_date_added":null,"published":"2022-02-13"},{"cvss_score":9.3,"headline":"ImpressCMS 1.4.4 - Unrestricted File Upload","id":"CVE-2022-50912","kev_date_added":null,"published":"2026-01-13"},{"cvss_score":8.1,"headline":"Path Traversal in ImpressCMS","id":"CVE-2021-26601","kev_date_added":null,"published":"2022-03-28"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2010-4271","kev_date_added":null,"published":"2010-11-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can bypass authentication in ImpressCMS due to a type confusion vulnerability in the autologin plugin.","url":"https://insights.sbomify.com/CVE-2021-26600/"}