# CVE-2021-26600: Type Confusion in ImpressCMS

> Attackers can bypass authentication in ImpressCMS due to a type confusion vulnerability in the autologin plugin.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-m8xh-cqc2-5q6f

## What is CVE-2021-26600?

CVE-2021-26600 is a critical authentication bypass vulnerability in n/a, published on 28 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant Authentication Bypass (!= instead of !==).

Weakness: CWE-843 (Access of Resource Using Incompatible Type)

## Which versions are affected by CVE-2021-26600?

2 open source packages ship an affected version, including impresscms/impresscms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `impresscms/impresscms` | Packagist | All versions | 1.4.3 |
| `impresscms/impresscms` | Packagist | All versions | 1.4.3 |

Products: Impresscms Impresscms.

## How do I fix CVE-2021-26600?

Upgrade impresscms/impresscms to 1.4.3 or later.

## Is CVE-2021-26600 being exploited?

There is no known exploitation of CVE-2021-26600 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2008-3453](https://insights.sbomify.com/CVE-2008-3453/): Multiple unspecified vulnerabilities in ImpressCMS 1.0 have unknown impact and attack vectors, related to modules/admin.php and "a few files (critical 10.0)
- [CVE-2021-26599](https://insights.sbomify.com/CVE-2021-26599/): SQL Injection in ImpressCMS (critical 9.8)
- [CVE-2022-24977](https://insights.sbomify.com/CVE-2022-24977/): Path Traversal in ImpressCMS (critical 9.8)
- [CVE-2022-50912](https://insights.sbomify.com/CVE-2022-50912/): ImpressCMS 1.4.4 - Unrestricted File Upload (critical 9.3)
- [CVE-2021-26601](https://insights.sbomify.com/CVE-2021-26601/): Path Traversal in ImpressCMS (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-26600 and fix it if it is affected.

What it is: CVE-2021-26600 is a critical authentication bypass vulnerability in n/a, published on 28 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-26600 in the wild and no public exploit code.

Affected packages and fixed versions:
- impresscms/impresscms (Packagist): affected all versions; fixed in 1.4.3
- impresscms/impresscms (Packagist): affected all versions; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-26600/ (Markdown: https://insights.sbomify.com/CVE-2021-26600/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-26600
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-26600
- OSV: https://osv.dev/vulnerability/CVE-2021-26600

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-26600/
Summaries are generated and may contain mistakes; the official description above is the record.
