# CVE-2021-26642: XpressEngine file upload vulnerability

> Remote attackers can upload arbitrary files to XpressEngine bulletin boards, leading to arbitrary code execution on the server.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jan 2023
- **Updated:** 3 Apr 2025
- **Also known as:** GHSA-8r5j-22j5-w4cm

## What is CVE-2021-26642?

CVE-2021-26642 is a high-severity vulnerability in XEHub XE3 XpresesEngine, published on 20 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

When uploading an image file to a bulletin board developed with XpressEngine, a vulnerability in which an arbitrary file can be uploaded due to insufficient verification of the file. A remote attacker can use this vulnerability to execute arbitrary code on the server where the bulletin board is running.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2021-26642?

2 open source packages ship an affected version, including xpressengine/xpressengine. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xpressengine/xpressengine` | Packagist | All versions | 3.0.15 |
| `xpressengine/xpressengine` | Packagist | All versions | 3.0.15 |

Products: Xpressengine Xpressengine.

## How do I fix CVE-2021-26642?

Upgrade xpressengine/xpressengine to 3.0.15 or later.

## Is CVE-2021-26642 being exploited?

There is no known exploitation of CVE-2021-26642 in the wild and no public exploit code.

## Other vulnerabilities in XEHub XE3 XpresesEngine

- [CVE-2011-10003](https://insights.sbomify.com/CVE-2011-10003/): XpressEngine Update Query sql injection (medium 5.5)
- [CVE-2021-44911](https://insights.sbomify.com/CVE-2021-44911/): File upload in n/a (medium 5.4)
- [CVE-2021-44912](https://insights.sbomify.com/CVE-2021-44912/): Cross-site scripting in n/a (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-26642 and fix it if it is affected.

What it is: CVE-2021-26642 is a high-severity vulnerability in XEHub XE3 XpresesEngine, published on 20 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-26642 in the wild and no public exploit code.

Affected packages and fixed versions:
- xpressengine/xpressengine (Packagist): affected all versions; fixed in 3.0.15
- xpressengine/xpressengine (Packagist): affected all versions; fixed in 3.0.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-26642/ (Markdown: https://insights.sbomify.com/CVE-2021-26642/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-26642
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-26642
- OSV: https://osv.dev/vulnerability/CVE-2021-26642

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-26642/
Summaries are generated and may contain mistakes; the official description above is the record.
