{"answers":{"affected":"1 open source package ship an affected version, including apache. It affects 8 products.","exploited":"There is no known exploitation of CVE-2021-26691 in the wild and no public exploit code.","fix":"Upgrade apache to 2.4.47 or later.","what":"CVE-2021-26691 is a critical memory corruption vulnerability in Apache Http Server, published on 10 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-26691 and fix it if it is affected.\n\nWhat it is: CVE-2021-26691 is a critical memory corruption vulnerability in Apache Http Server, published on 10 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-26691 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache (Bitnami): affected from 2.4.0; fixed in 2.4.47\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-26691/ (Markdown: https://insights.sbomify.com/CVE-2021-26691/index.md)","id":"CVE-2021-26691","markdown":"https://insights.sbomify.com/CVE-2021-26691/index.md","name":"CVE-2021-26691","record":{"aliases":["ALPINE-CVE-2021-26691","AZL-6477","BIT-apache-2021-26691","CLEANSTART-2026-QB44959","DEBIAN-CVE-2021-26691","GHSA-j3ww-p97m-gh9x","UBUNTU-CVE-2021-26691"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache HTTP Server","requires_auth":"none","summary":"A heap overflow in Apache HTTP Server's mod_session allows attackers to execute arbitrary code or cause a denial of service via crafted headers.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"http_server","vendor":"apache"},{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"cloud_backup","vendor":"netapp"},{"product":"enterprise_manager_ops_center","vendor":"oracle"},{"product":"instantis_enterprisetrack","vendor":"oracle"},{"product":"secure_backup","vendor":"oracle"},{"product":"zfs_storage_appliance_kit","vendor":"oracle"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"In Apache HTTP Server versions 2.4.0 to 2.4.46 a specially crafted SessionHeader sent by an origin server could cause a heap overflow","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache HTTP Server mod_session response handling heap overflow","id":"CVE-2021-26691","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:http_server","products":["apache:http_server","debian:debian_linux","fedoraproject:fedora","netapp:cloud_backup","oracle:enterprise_manager_ops_center","oracle:instantis_enterprisetrack","oracle:zfs_storage_appliance_kit"],"type":"memory_corruption","year":"2021"},"n_packages":1,"n_references":13,"next":{"headline":"Apache Airflow: Lineage API endpoint for Experimental API missed authentication check","id":"CVE-2021-26697"},"packages":[{"ecosystem":"Bitnami","fixed":["2.4.47"],"introduced":["2.4.0"],"last_affected":[],"package":"apache","purl":"pkg:bitnami/apache","source":"BIT-apache-2021-26691"}],"prev":{"headline":"mod_session NULL pointer dereference","id":"CVE-2021-26690"},"products":["Apache HTTP Server"],"published":"2021-06-10","related":[{"cvss_score":9.8,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-42013","kev_date_added":"2021-11-03","published":"2021-10-07"},{"cvss_score":9.1,"headline":"Apache HTTP Server Improper Escaping of Output","id":"CVE-2024-38475","kev_date_added":"2025-05-01","published":"2024-07-01"},{"cvss_score":9,"headline":"Apache HTTP Server-Side Request Forgery (SSRF)","id":"CVE-2021-40438","kev_date_added":"2021-12-01","published":"2021-09-16"},{"cvss_score":7.8,"headline":"Apache HTTP Server Privilege Escalation","id":"CVE-2019-0211","kev_date_added":"2021-11-03","published":"2019-04-08"},{"cvss_score":7.5,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-41773","kev_date_added":"2021-11-03","published":"2021-10-05"},{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2010-0425","kev_date_added":null,"published":"2010-03-05"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2005-2700","kev_date_added":null,"published":"2005-09-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Apache Software Foundation"]},"summary":"A heap overflow in Apache HTTP Server's mod_session allows attackers to execute arbitrary code or cause a denial of service via crafted headers.","url":"https://insights.sbomify.com/CVE-2021-26691/"}