# CVE-2021-26691: Apache HTTP Server mod_session response handling heap overflow

> A heap overflow in Apache HTTP Server's mod_session allows attackers to execute arbitrary code or cause a denial of service via crafted headers.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2021-26691, AZL-6477, BIT-apache-2021-26691, CLEANSTART-2026-QB44959, DEBIAN-CVE-2021-26691, GHSA-j3ww-p97m-gh9x, UBUNTU-CVE-2021-26691

## What is CVE-2021-26691?

CVE-2021-26691 is a critical memory corruption vulnerability in Apache Http Server, published on 10 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache HTTP Server versions 2.4.0 to 2.4.46 a specially crafted SessionHeader sent by an origin server could cause a heap overflow

Weakness: CWE-787 (Out-of-bounds Write), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2021-26691?

1 open source package ship an affected version, including apache. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.0 | 2.4.47 |

Products: Apache Http Server, Debian Debian Linux, Fedoraproject Fedora, Netapp Cloud Backup, Oracle Enterprise Manager Ops Center, Oracle Instantis Enterprisetrack, Oracle Secure Backup, Oracle Zfs Storage Appliance Kit.

## How do I fix CVE-2021-26691?

Upgrade apache to 2.4.47 or later.

## Is CVE-2021-26691 being exploited?

There is no known exploitation of CVE-2021-26691 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-26691 and fix it if it is affected.

What it is: CVE-2021-26691 is a critical memory corruption vulnerability in Apache Http Server, published on 10 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-26691 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.0; fixed in 2.4.47

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-26691/ (Markdown: https://insights.sbomify.com/CVE-2021-26691/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-26691
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-26691
- OSV: https://osv.dev/vulnerability/CVE-2021-26691

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-26691/
Summaries are generated and may contain mistakes; the official description above is the record.
