# CVE-2021-26707: Prototype pollution in Merge-deep

> The merge-deep library allows prototype pollution, enabling attackers to modify Object.prototype and potentially execute code or escalate privileges in Node.js applications.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-r6rj-9ch6-g264, ROOT-APP-NPM-CVE-2021-26707

## What is CVE-2021-26707?

CVE-2021-26707 is a critical vulnerability in Netapp E-Series Performance Analyzer, published on 2 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The merge-deep library before 3.0.3 for Node.js can be tricked into overwriting properties of Object.prototype or adding new properties to it. These properties are then inherited by every object in the program, thus facilitating prototype-pollution attacks against applications using this library.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2021-26707?

2 open source packages ship an affected version, including merge-deep. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `merge-deep` | npm | All versions | 3.0.3 |
| `merge-deep` | npm | All versions | 3.0.3 |

Products: Merge-Deep Project Merge-Deep, Netapp E-Series Performance Analyzer.

## How do I fix CVE-2021-26707?

Upgrade merge-deep to 3.0.3 or later.

## Is CVE-2021-26707 being exploited?

There is no known exploitation of CVE-2021-26707 in the wild and no public exploit code.

## Other vulnerabilities in Netapp E-Series Performance Analyzer

- [CVE-2018-3722](https://insights.sbomify.com/CVE-2018-3722/): Prototype Pollution in merge-deep (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-26707 and fix it if it is affected.

What it is: CVE-2021-26707 is a critical vulnerability in Netapp E-Series Performance Analyzer, published on 2 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-26707 in the wild and no public exploit code.

Affected packages and fixed versions:
- merge-deep (npm): affected all versions; fixed in 3.0.3
- merge-deep (npm): affected all versions; fixed in 3.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-26707/ (Markdown: https://insights.sbomify.com/CVE-2021-26707/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-26707
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-26707
- OSV: https://osv.dev/vulnerability/CVE-2021-26707

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-26707/
Summaries are generated and may contain mistakes; the official description above is the record.
