# CVE-2021-26722: LinkedIn Oncall vulnerable to Cross-Site Scripting

> Reflected XSS in LinkedIn Oncall allows attackers to execute arbitrary scripts via the search bar, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-rfw2-x9f8-2f6m, PYSEC-2021-33

## What is CVE-2021-26722?

CVE-2021-26722 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

LinkedIn Oncall through 1.4.0 allows reflected XSS via /query because of mishandling of the "No results found for" message in the search bar.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-26722?

3 open source packages ship an affected version, including oncall. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oncall` | PyPI | All versions | 1.4.1 |
| `oncall` | PyPI | All versions | 1.4.1 |
| `oncall` | PyPI | All versions | 1.4.1 |

Products: Linkedin Oncall.

## How do I fix CVE-2021-26722?

Upgrade oncall to 1.4.1 or later.

## Is CVE-2021-26722 being exploited?

There is no known exploitation of CVE-2021-26722 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-26722 and fix it if it is affected.

What it is: CVE-2021-26722 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-26722 in the wild and no public exploit code.

Affected packages and fixed versions:
- oncall (PyPI): affected all versions; fixed in 1.4.1
- oncall (PyPI): affected all versions; fixed in 1.4.1
- oncall (PyPI): affected all versions; fixed in 1.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-26722/ (Markdown: https://insights.sbomify.com/CVE-2021-26722/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-26722
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-26722
- OSV: https://osv.dev/vulnerability/CVE-2021-26722

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-26722/
Summaries are generated and may contain mistakes; the official description above is the record.
