CVE-2021-26813 markdown2 Regular Expression Denial of Service
An attacker can cause a denial of service in the markdown2 library by providing a malicious string that triggers excessive processing time.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-26813?
CVE-2021-26813 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 3 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
markdown2 >=1.0.1.18, fixed in 2.4.0, is affected by a regular expression denial of service vulnerability. If an attacker provides a malicious string, it can make markdown2 processing difficult or delayed for an extended period of time.
Weakness: CWE-1333
Which versions are affected by CVE-2021-26813?
3 open source packages ship an affected version, including markdown2. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
markdown2 PyPI | From 1.0.1.18 | 2.4.0 |
markdown2 PyPI | From 1.0.1.18 | 2.4.0 |
markdown2 PyPI | From 1.0.1.18 | 2.4.0 |
Linux distribution packages (2)
python-markdown2 SUSE:Package Hub 15 SP2 | All versions | 2.4.0-bp152.2.4.1 |
python-markdown2 openSUSE:Leap 15.2 | All versions | 2.4.0-lp152.2.3.1 |
Products include Fedoraproject Fedora, Markdown2 Project Markdown2.
How do I fix CVE-2021-26813?
Upgrade markdown2 to 2.4.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-26813 being exploited?
There is no known exploitation of CVE-2021-26813 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as DEBIAN-CVE-2021-26813, GHSA-jr9p-r423-9m2r, PYSEC-2021-20, UBUNTU-CVE-2021-26813, openSUSE-SU-2021:0429-1, openSUSE-SU-2021:0451-1.