# CVE-2021-26813: markdown2 Regular Expression Denial of Service

> An attacker can cause a denial of service in the markdown2 library by providing a malicious string that triggers excessive processing time.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-26813, GHSA-jr9p-r423-9m2r, PYSEC-2021-20, UBUNTU-CVE-2021-26813, openSUSE-SU-2021:0429-1, openSUSE-SU-2021:0451-1

## What is CVE-2021-26813?

CVE-2021-26813 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 3 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

markdown2 >=1.0.1.18, fixed in 2.4.0, is affected by a regular expression denial of service vulnerability. If an attacker provides a malicious string, it can make markdown2 processing difficult or delayed for an extended period of time.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-26813?

3 open source packages ship an affected version, including markdown2. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `markdown2` | PyPI | From 1.0.1.18 | 2.4.0 |
| `markdown2` | PyPI | From 1.0.1.18 | 2.4.0 |
| `markdown2` | PyPI | From 1.0.1.18 | 2.4.0 |
| `python-markdown2` | SUSE:Package Hub 15 SP2 | All versions | 2.4.0-bp152.2.4.1 |
| `python-markdown2` | openSUSE:Leap 15.2 | All versions | 2.4.0-lp152.2.3.1 |

Products: Fedoraproject Fedora, Markdown2 Project Markdown2.

## How do I fix CVE-2021-26813?

Upgrade markdown2 to 2.4.0 or later.

## Is CVE-2021-26813 being exploited?

There is no known exploitation of CVE-2021-26813 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-26813 and fix it if it is affected.

What it is: CVE-2021-26813 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 3 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-26813 in the wild and no public exploit code.

Affected packages and fixed versions:
- markdown2 (PyPI): affected from 1.0.1.18; fixed in 2.4.0
- markdown2 (PyPI): affected from 1.0.1.18; fixed in 2.4.0
- markdown2 (PyPI): affected from 1.0.1.18; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-26813/ (Markdown: https://insights.sbomify.com/CVE-2021-26813/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-26813
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-26813
- OSV: https://osv.dev/vulnerability/CVE-2021-26813

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-26813/
Summaries are generated and may contain mistakes; the official description above is the record.
