# CVE-2021-26953: Read on uninitialized buffer in postscript

> Attackers can read sensitive data from uninitialized memory in the postscript crate via a malicious Read implementation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-fhvc-gp6c-h2wx, RUSTSEC-2021-0017

## What is CVE-2021-26953?

CVE-2021-26953 is a high-severity vulnerability in n/a, published on 9 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the postscript crate before 0.14.0 for Rust. It might allow attackers to obtain sensitive information from uninitialized memory locations via a user-provided Read implementation.

Weakness: CWE-908 (Use of Uninitialized Resource)

## Which versions are affected by CVE-2021-26953?

3 open source packages ship an affected version, including postscript. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postscript` | crates.io | All versions | 0.14.0 |
| `postscript` | crates.io | All versions | 0.14.0 |
| `postscript` | crates.io | From 0.0.0-0 | 0.14.0 |

Products: Postscript Project Postscript.

## How do I fix CVE-2021-26953?

Upgrade postscript to 0.14.0 or later.

## Is CVE-2021-26953 being exploited?

There is no known exploitation of CVE-2021-26953 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-26953 and fix it if it is affected.

What it is: CVE-2021-26953 is a high-severity vulnerability in n/a, published on 9 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-26953 in the wild and no public exploit code.

Affected packages and fixed versions:
- postscript (crates.io): affected all versions; fixed in 0.14.0
- postscript (crates.io): affected all versions; fixed in 0.14.0
- postscript (crates.io): affected from 0.0.0-0; fixed in 0.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-26953/ (Markdown: https://insights.sbomify.com/CVE-2021-26953/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-26953
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-26953
- OSV: https://osv.dev/vulnerability/CVE-2021-26953

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-26953/
Summaries are generated and may contain mistakes; the official description above is the record.
