# CVE-2021-26954: insert_slice_clone can double drop if Clone panics.

> A double drop vulnerability in the qwutils Rust crate allows attackers to cause memory corruption, potentially leading to crashes or arbitrary code execution.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-68p4-pjpf-xwcq, RUSTSEC-2021-0018

## What is CVE-2021-26954?

CVE-2021-26954 is a medium-severity use after free vulnerability in n/a, published on 9 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the qwutils crate before 0.3.1 for Rust. When a Clone panic occurs, insert_slice_clone can perform a double drop.

Weakness: CWE-415 (Double Free)

## Which versions are affected by CVE-2021-26954?

3 open source packages ship an affected version, including qwutils. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qwutils` | crates.io | All versions | 0.3.1 |
| `qwutils` | crates.io | All versions | 0.3.1 |
| `qwutils` | crates.io | From 0.0.0-0 | 0.3.1 |

Products: Qwutils Project Qwutils.

## How do I fix CVE-2021-26954?

Upgrade qwutils to 0.3.1 or later.

## Is CVE-2021-26954 being exploited?

There is no known exploitation of CVE-2021-26954 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-26954 and fix it if it is affected.

What it is: CVE-2021-26954 is a medium-severity use after free vulnerability in n/a, published on 9 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-26954 in the wild and no public exploit code.

Affected packages and fixed versions:
- qwutils (crates.io): affected all versions; fixed in 0.3.1
- qwutils (crates.io): affected all versions; fixed in 0.3.1
- qwutils (crates.io): affected from 0.0.0-0; fixed in 0.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-26954/ (Markdown: https://insights.sbomify.com/CVE-2021-26954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-26954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-26954
- OSV: https://osv.dev/vulnerability/CVE-2021-26954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-26954/
Summaries are generated and may contain mistakes; the official description above is the record.
