CVE-2021-27098 Legacy Node API Allows Impersonation in github.com/spiffe/spire/pkg/server/endpoints/node
An authenticated agent can request X.509 certificates for unauthorized SPIFFE IDs within its trust domain, bypassing authorization controls.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-27098?
CVE-2021-27098 is a high-severity missing authorization vulnerability in n/a, published on 5 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In SPIRE 0.8.1 through 0.8.4 and before versions 0.9.4, 0.10.2, 0.11.3 and 0.12.1, specially crafted requests to the FetchX509SVID RPC of SPIRE Server’s Legacy Node API can result in the possible issuance of an X.509 certificate with a URI SAN for a SPIFFE ID that the agent is not authorized to distribute. Proper controls are in place to require that the caller presents a valid agent certificate that is already authorized to issue at least one SPIFFE ID, and the requested SPIFFE ID belongs to the same trust domain, prior to being able to trigger this vulnerability. This issue has been fixed in SPIRE versions 0.8.5, 0.9.4, 0.10.2, 0.11.3 and 0.12.1.
Weakness: CWE-295
Which versions are affected by CVE-2021-27098?
10 open source packages ship an affected version, including github.com/spiffe/spire. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/spiffe/spire Go | From 0.10.0 | 0.10.2 |
github.com/spiffe/spire Go | From 0.10.0 | 0.10.2 |
github.com/spiffe/spire Go | From 0.11.0 | 0.11.3 |
github.com/spiffe/spire Go | From 0.11.0 | 0.11.3 |
github.com/spiffe/spire Go | From 0.12.0 | 0.12.1 |
github.com/spiffe/spire Go | From 0.12.0 | 0.12.1 |
4 more packages
github.com/spiffe/spire Go | From 0.8.1 | 0.8.5 |
github.com/spiffe/spire Go | From 0.8.1 | 0.8.5 |
github.com/spiffe/spire Go | From 0.9.0 | 0.9.4 |
github.com/spiffe/spire Go | From 0.9.0 | 0.9.4 |
Products include Cncf Spire.
How do I fix CVE-2021-27098?
Upgrade github.com/spiffe/spire to a fixed version for your release line: 0.10.2, 0.11.3, 0.12.1 or 0.8.5.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-27098 being exploited?
There is no known exploitation of CVE-2021-27098 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-h746-rm5q-8mgq.