# CVE-2021-27098: Legacy Node API Allows Impersonation in github.com/spiffe/spire/pkg/server/endpoints/node

> An authenticated agent can request X.509 certificates for unauthorized SPIFFE IDs within its trust domain, bypassing authorization controls.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-h746-rm5q-8mgq

## What is CVE-2021-27098?

CVE-2021-27098 is a high-severity missing authorization vulnerability in n/a, published on 5 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In SPIRE 0.8.1 through 0.8.4 and before versions 0.9.4, 0.10.2, 0.11.3 and 0.12.1, specially crafted requests to the FetchX509SVID RPC of SPIRE Server’s Legacy Node API can result in the possible issuance of an X.509 certificate with a URI SAN for a SPIFFE ID that the agent is not authorized to distribute. Proper controls are in place to require that the caller presents a valid agent certificate that is already authorized to issue at least one SPIFFE ID, and the requested SPIFFE ID belongs to the same trust domain, prior to being able to trigger this vulnerability. This issue has been fixed in SPIRE versions 0.8.5, 0.9.4, 0.10.2, 0.11.3 and 0.12.1.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2021-27098?

10 open source packages ship an affected version, including github.com/spiffe/spire. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/spiffe/spire` | Go | From 0.10.0 | 0.10.2 |
| `github.com/spiffe/spire` | Go | From 0.10.0 | 0.10.2 |
| `github.com/spiffe/spire` | Go | From 0.11.0 | 0.11.3 |
| `github.com/spiffe/spire` | Go | From 0.11.0 | 0.11.3 |
| `github.com/spiffe/spire` | Go | From 0.12.0 | 0.12.1 |
| `github.com/spiffe/spire` | Go | From 0.12.0 | 0.12.1 |
| `github.com/spiffe/spire` | Go | From 0.8.1 | 0.8.5 |
| `github.com/spiffe/spire` | Go | From 0.8.1 | 0.8.5 |
| `github.com/spiffe/spire` | Go | From 0.9.0 | 0.9.4 |
| `github.com/spiffe/spire` | Go | From 0.9.0 | 0.9.4 |

Products: Cncf Spire.

## How do I fix CVE-2021-27098?

Upgrade github.com/spiffe/spire to a fixed version for your release line: 0.10.2, 0.11.3, 0.12.1 or 0.8.5.

## Is CVE-2021-27098 being exploited?

There is no known exploitation of CVE-2021-27098 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-27099](https://insights.sbomify.com/CVE-2021-27099/): Missing authorization in n/a (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27098 and fix it if it is affected.

What it is: CVE-2021-27098 is a high-severity missing authorization vulnerability in n/a, published on 5 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-27098 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/spiffe/spire (Go): affected from 0.10.0; fixed in 0.10.2
- github.com/spiffe/spire (Go): affected from 0.10.0; fixed in 0.10.2
- github.com/spiffe/spire (Go): affected from 0.11.0; fixed in 0.11.3
- github.com/spiffe/spire (Go): affected from 0.11.0; fixed in 0.11.3
- github.com/spiffe/spire (Go): affected from 0.12.0; fixed in 0.12.1
- github.com/spiffe/spire (Go): affected from 0.12.0; fixed in 0.12.1
- github.com/spiffe/spire (Go): affected from 0.8.1; fixed in 0.8.5
- github.com/spiffe/spire (Go): affected from 0.8.1; fixed in 0.8.5
- github.com/spiffe/spire (Go): affected from 0.9.0; fixed in 0.9.4
- github.com/spiffe/spire (Go): affected from 0.9.0; fixed in 0.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27098/ (Markdown: https://insights.sbomify.com/CVE-2021-27098/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27098
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27098
- OSV: https://osv.dev/vulnerability/CVE-2021-27098

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27098/
Summaries are generated and may contain mistakes; the official description above is the record.
