{"answers":{"affected":"3 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-27131 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2021-27131 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 16 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-27131 and fix it if it is affected.\n\nWhat it is: CVE-2021-27131 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 16 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-27131 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected all versions up to 3.10.1; no fix listed\n- moodle/moodle (Packagist): affected all versions up to 3.10.1; no fix listed\n- moodle (Bitnami): affected from 3.10.1; fixed in 3.10.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-27131/ (Markdown: https://insights.sbomify.com/CVE-2021-27131/index.md)","id":"CVE-2021-27131","markdown":"https://insights.sbomify.com/CVE-2021-27131/index.md","name":"CVE-2021-27131","record":{"aliases":["BIT-moodle-2021-27131","GHSA-w2pm-fr62-jgv4"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"Stored XSS in Moodle allows attackers to steal admin and user cookies via the Header and Footer settings, though the vendor disputes this as intended admin functionality.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Moodle 3.10.1 is vulnerable to persistent/stored cross-site scripting (XSS) due to the improper input sanitization on the \"Additional HTML Section\" via \"Header and Footer\" parameter in /admin/settings.php. This vulnerability is leading an attacker to steal admin and all user account cookies by storing the malicious XSS payload in Header and Footer. NOTE: this is disputed by the vendor because the \"Additional HTML Section\" for \"Header and Footer\" can only be supplied by an administrator, who is intentionally allowed to enter unsanitized input (e.g., site-specific JavaScript).","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle vulnerable to stored Cross-site Scripting","id":"CVE-2021-27131","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"xss","year":"2021"},"n_packages":3,"n_references":3,"next":{"headline":"Other in n/a","id":"CVE-2021-27132"},"packages":[{"ecosystem":"Bitnami","fixed":["3.10.2"],"introduced":["3.10.1"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2021-27131"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["3.10.1"],"package":"moodle/moodle","purl":null,"source":"GHSA-w2pm-fr62-jgv4"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["3.10.1"],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-w2pm-fr62-jgv4"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2021-27130"},"products":["n/a"],"published":"2023-05-16","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Stored XSS in Moodle allows attackers to steal admin and user cookies via the Header and Footer settings, though the vendor disputes this as intended admin functionality.","url":"https://insights.sbomify.com/CVE-2021-27131/"}