# CVE-2021-27131: Moodle vulnerable to stored Cross-site Scripting

> Stored XSS in Moodle allows attackers to steal admin and user cookies via the Header and Footer settings, though the vendor disputes this as intended admin functionality.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 May 2023
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-moodle-2021-27131, GHSA-w2pm-fr62-jgv4

## What is CVE-2021-27131?

CVE-2021-27131 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 16 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Moodle 3.10.1 is vulnerable to persistent/stored cross-site scripting (XSS) due to the improper input sanitization on the "Additional HTML Section" via "Header and Footer" parameter in /admin/settings.php. This vulnerability is leading an attacker to steal admin and all user account cookies by storing the malicious XSS payload in Header and Footer. NOTE: this is disputed by the vendor because the "Additional HTML Section" for "Header and Footer" can only be supplied by an administrator, who is intentionally allowed to enter unsanitized input (e.g., site-specific JavaScript).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-27131?

3 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions to 3.10.1 | None |
| `moodle/moodle` | Packagist | All versions to 3.10.1 | None |
| `moodle` | Bitnami | From 3.10.1 | 3.10.2 |

Products: Moodle Moodle.

## How do I fix CVE-2021-27131?

Apply the vendor's patch.

## Is CVE-2021-27131 being exploited?

There is no known exploitation of CVE-2021-27131 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27131 and fix it if it is affected.

What it is: CVE-2021-27131 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 16 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-27131 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions up to 3.10.1; no fix listed
- moodle/moodle (Packagist): affected all versions up to 3.10.1; no fix listed
- moodle (Bitnami): affected from 3.10.1; fixed in 3.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27131/ (Markdown: https://insights.sbomify.com/CVE-2021-27131/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27131
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27131
- OSV: https://osv.dev/vulnerability/CVE-2021-27131

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27131/
Summaries are generated and may contain mistakes; the official description above is the record.
