# CVE-2021-27186: Null dereference in n/a

> A NULL pointer dereference in Fluent Bit allows attackers to cause a denial of service via unvalidated memory allocation returns.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-fluent-bit-2021-27186, GHSA-gjm8-qc7w-3xxp

## What is CVE-2021-27186?

CVE-2021-27186 is a high-severity vulnerability in n/a, published on 10 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fluent Bit 1.6.10 has a NULL pointer dereference when an flb_malloc return value is not validated by flb_avro.c or http_server/api/v1/metrics.c.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2021-27186?

1 open source package ship an affected version, including fluent-bit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluent-bit` | Bitnami | From 1.6.10 | 1.6.11 |

Products: Treasuredata Fluent Bit.

## How do I fix CVE-2021-27186?

Upgrade fluent-bit to 1.6.11 or later.

## Is CVE-2021-27186 being exploited?

There is no known exploitation of CVE-2021-27186 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-4323](https://insights.sbomify.com/CVE-2024-4323/): Fluent Bit Memory Corruption Vulnerability (critical 9.8)
- [CVE-2021-36088](https://insights.sbomify.com/CVE-2021-36088/): Use after free in n/a (critical 9.8)
- [CVE-2025-12977](https://insights.sbomify.com/CVE-2025-12977/): CVE-2025-12977 (critical 9.1)
- [CVE-2025-12970](https://insights.sbomify.com/CVE-2025-12970/): CVE-2025-12970 (high 8.8)
- [CVE-2021-46878](https://insights.sbomify.com/CVE-2021-46878/): Use after free in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27186 and fix it if it is affected.

What it is: CVE-2021-27186 is a high-severity vulnerability in n/a, published on 10 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-27186 in the wild and no public exploit code.

Affected packages and fixed versions:
- fluent-bit (Bitnami): affected from 1.6.10; fixed in 1.6.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27186/ (Markdown: https://insights.sbomify.com/CVE-2021-27186/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27186
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27186
- OSV: https://osv.dev/vulnerability/CVE-2021-27186

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27186/
Summaries are generated and may contain mistakes; the official description above is the record.
