CVE-2021-27191 Denial of Service in get-ip-range

High 7.5 Published Updated

An attacker can cause resource exhaustion and denial of service by providing a large IP range to the get-ip-range Node.js package.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-27191?

CVE-2021-27191 is a high-severity denial of service vulnerability in n/a, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The get-ip-range package before 4.0.0 for Node.js is vulnerable to denial of service (DoS) if the range is untrusted input. An attacker could send a large range (such as 128.0.0.0/1) that causes resource exhaustion.

Which versions are affected by CVE-2021-27191?

2 open source packages ship an affected version, including get-ip-range. It affects 1 product.

PackageAffectedFixed in
get-ip-range npmAll versions4.0.0
get-ip-range npmAll versions4.0.0

Products include Get-Ip-Range Project Get-Ip-Range.

How do I fix CVE-2021-27191?

Upgrade get-ip-range to 4.0.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-27191 being exploited?

There is no known exploitation of CVE-2021-27191 in the wild and no public exploit code.

Sources

Also known as GHSA-6q4w-3wp4-q5wf.

Is CVE-2021-27191 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free