{"answers":{"affected":"2 open source packages ship an affected version, including get-ip-range. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-27191 in the wild and no public exploit code.","fix":"Upgrade get-ip-range to 4.0.0 or later.","what":"CVE-2021-27191 is a high-severity denial of service vulnerability in n/a, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-27191 and fix it if it is affected.\n\nWhat it is: CVE-2021-27191 is a high-severity denial of service vulnerability in n/a, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-27191 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- get-ip-range (npm): affected all versions; fixed in 4.0.0\n- get-ip-range (npm): affected all versions; fixed in 4.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-27191/ (Markdown: https://insights.sbomify.com/CVE-2021-27191/index.md)","id":"CVE-2021-27191","markdown":"https://insights.sbomify.com/CVE-2021-27191/index.md","name":"CVE-2021-27191","record":{"aliases":["GHSA-6q4w-3wp4-q5wf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js IP range library","requires_auth":"none","summary":"An attacker can cause resource exhaustion and denial of service by providing a large IP range to the get-ip-range Node.js package.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"get-ip-range","vendor":"get-ip-range_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"The get-ip-range package before 4.0.0 for Node.js is vulnerable to denial of service (DoS) if the range is untrusted input. An attacker could send a large range (such as 128.0.0.0/1) that causes resource exhaustion.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service in get-ip-range","id":"CVE-2021-27191","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2021-27192"},"packages":[{"ecosystem":"npm","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"get-ip-range","purl":null,"source":"GHSA-6q4w-3wp4-q5wf"},{"ecosystem":"npm","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"get-ip-range","purl":"pkg:npm/get-ip-range","source":"GHSA-6q4w-3wp4-q5wf"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2021-27190"},"products":["n/a"],"published":"2021-02-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"An attacker can cause resource exhaustion and denial of service by providing a large IP range to the get-ip-range Node.js package.","url":"https://insights.sbomify.com/CVE-2021-27191/"}