# CVE-2021-27191: Denial of Service in get-ip-range

> An attacker can cause resource exhaustion and denial of service by providing a large IP range to the get-ip-range Node.js package.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-6q4w-3wp4-q5wf

## What is CVE-2021-27191?

CVE-2021-27191 is a high-severity denial of service vulnerability in n/a, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The get-ip-range package before 4.0.0 for Node.js is vulnerable to denial of service (DoS) if the range is untrusted input. An attacker could send a large range (such as 128.0.0.0/1) that causes resource exhaustion.

## Which versions are affected by CVE-2021-27191?

2 open source packages ship an affected version, including get-ip-range. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `get-ip-range` | npm | All versions | 4.0.0 |
| `get-ip-range` | npm | All versions | 4.0.0 |

Products: Get-Ip-Range Project Get-Ip-Range.

## How do I fix CVE-2021-27191?

Upgrade get-ip-range to 4.0.0 or later.

## Is CVE-2021-27191 being exploited?

There is no known exploitation of CVE-2021-27191 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27191 and fix it if it is affected.

What it is: CVE-2021-27191 is a high-severity denial of service vulnerability in n/a, published on 11 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-27191 in the wild and no public exploit code.

Affected packages and fixed versions:
- get-ip-range (npm): affected all versions; fixed in 4.0.0
- get-ip-range (npm): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27191/ (Markdown: https://insights.sbomify.com/CVE-2021-27191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27191
- OSV: https://osv.dev/vulnerability/CVE-2021-27191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27191/
Summaries are generated and may contain mistakes; the official description above is the record.
