# CVE-2021-27212: Denial of service in n/a

> An attacker can cause a denial of service in OpenLDAP slapd by sending a crafted packet with a short timestamp, triggering an assertion failure.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2021
- **Updated:** 14 Oct 2026
- **Also known as:** ALPINE-CVE-2021-27212, AZL-6771, BIT-openldap-2021-27212, CLEANSTART-2026-QG21106, CLSA-2021-1637770462, CLSA-2021-1638803748, CLSA-2022-1646915783, DEBIAN-CVE-2021-27212, DLA-2574-1, DSA-4860-1, GHSA-274h-c788-hf3c, JLSEC-2026-173, OESA-2021-1119, UBUNTU-CVE-2021-27212, USN-4744-1

## What is CVE-2021-27212?

CVE-2021-27212 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 14 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In OpenLDAP through 2.4.57 and 2.5.x through 2.5.1alpha, an assertion failure in slapd can occur in the issuerAndThisUpdateCheck function via a crafted packet, resulting in a denial of service (daemon exit) via a short timestamp. This is related to schema_init.c and checkTime.

Weakness: CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2021-27212?

1 open source package ship an affected version, including openldap. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openldap` | Bitnami | All versions | 2.4.58 |

Products: Debian Debian Linux, Openldap Openldap.

## How do I fix CVE-2021-27212?

Upgrade openldap to 2.4.58 or later.

## Is CVE-2021-27212 being exploited?

There is no known exploitation of CVE-2021-27212 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27212 and fix it if it is affected.

What it is: CVE-2021-27212 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 14 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-27212 in the wild and no public exploit code.

Affected packages and fixed versions:
- openldap (Bitnami): affected all versions; fixed in 2.4.58

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27212/ (Markdown: https://insights.sbomify.com/CVE-2021-27212/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27212
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27212
- OSV: https://osv.dev/vulnerability/CVE-2021-27212

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27212/
Summaries are generated and may contain mistakes; the official description above is the record.
