# CVE-2021-27291: Pygments vulnerable to Regular Expression Denial of Service (ReDoS)

> Attackers can cause denial of service in Pygments by submitting malicious input that triggers exponential complexity in regular expressions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2021-27291, AZL-35138, AZL-6812, DEBIAN-CVE-2021-27291, DLA-2600-1, DSA-4878-1, GHSA-pq64-v7f5-gqh8, MGASA-2021-0245, MINI-cwpv-qv63-x845, PYSEC-2021-141, SUSE-SU-2021:3814-1, SUSE-SU-2021:3839-1, SUSE-SU-2021:3840-1, SUSE-SU-2021:3841-1, UBUNTU-CVE-2021-27291, USN-4897-1, openSUSE-SU-2021:1521-1, openSUSE-SU-2021:3839-1, openSUSE-SU-2021:3841-1

## What is CVE-2021-27291?

CVE-2021-27291 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 17 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-27291?

3 open source packages ship an affected version, including pygments and Pygments. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pygments` | PyPI | From 1.1 | 2.7.4 |
| `pygments` | PyPI | From 1.1 | 2.7.4 |
| `Pygments` | PyPI | From 1.1 | 2.7.4 |
| `python-Pygments` | SUSE:Enterprise Storage 6 | All versions | 2.6.1-7.10.1 |
| `python-Pygments` | SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS | All versions | 2.6.1-7.10.1 |
| `python-Pygments` | SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 2.6.1-7.10.1 |
| `python-Pygments` | SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 2.2.0-4.9.1 |
| `python-Pygments` | SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 2.2.0-4.9.1 |
| `python-Pygments` | SUSE:Linux Enterprise Module for Basesystem 15 SP2 | All versions | 2.6.1-7.10.1 |
| `python-Pygments` | SUSE:Linux Enterprise Module for Basesystem 15 SP3 | All versions | 2.6.1-4.3.1 |
| `python-Pygments` | SUSE:Linux Enterprise Module for Package Hub 15 SP2 | All versions | 2.2.0-4.9.1 |
| `python-Pygments` | SUSE:Linux Enterprise Module for Package Hub 15 SP3 | All versions | 2.2.0-4.9.1 |
| `python-Pygments` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 2.4.2-10.7.1 |
| `python-Pygments` | SUSE:Linux Enterprise Server 15 SP1-BCL | All versions | 2.6.1-7.10.1 |
| `python-Pygments` | SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 2.6.1-7.10.1 |
| `python-Pygments` | SUSE:Linux Enterprise Server 15-LTSS | All versions | 2.2.0-4.9.1 |
| `python-Pygments` | SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 2.2.0-4.9.1 |
| `python-Pygments` | SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 2.6.1-7.10.1 |
| `python-Pygments` | openSUSE:Leap 15.2 | All versions | 2.6.1-lp152.5.12.1 |
| `python-Pygments` | openSUSE:Leap 15.3 | All versions | 2.2.0-4.9.1 |
| `python-Pygments` | openSUSE:Leap 15.3 | All versions | 2.6.1-4.3.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Pygments Pygments.

## How do I fix CVE-2021-27291?

Upgrade pygments to 2.7.4 or later.

## Is CVE-2021-27291 being exploited?

There is no known exploitation of CVE-2021-27291 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27291 and fix it if it is affected.

What it is: CVE-2021-27291 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 17 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-27291 in the wild and no public exploit code.

Affected packages and fixed versions:
- pygments (PyPI): affected from 1.1; fixed in 2.7.4
- pygments (PyPI): affected from 1.1; fixed in 2.7.4
- Pygments (PyPI): affected from 1.1; fixed in 2.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27291/ (Markdown: https://insights.sbomify.com/CVE-2021-27291/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27291
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27291
- OSV: https://osv.dev/vulnerability/CVE-2021-27291

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27291/
Summaries are generated and may contain mistakes; the official description above is the record.
