CVE-2021-27292 Regular Expression Denial of Service (ReDoS) in ua-parser-js

High 7.5 Published Updated

Attackers can cause denial of service in applications using ua-parser-js by sending malicious User-Agent headers that trigger excessive regex processing.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-27292?

CVE-2021-27292 is a high-severity denial of service vulnerability in n/a, published on 17 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.

Which versions are affected by CVE-2021-27292?

2 open source packages ship an affected version, including ua-parser-js. It affects 1 product.

PackageAffectedFixed in
ua-parser-js npmFrom 0.7.140.7.24
ua-parser-js npmFrom 0.7.140.7.24

Products include Ua-Parser-Js Project Ua-Parser-Js.

How do I fix CVE-2021-27292?

Upgrade ua-parser-js to 0.7.24 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-27292 being exploited?

There is no known exploitation of CVE-2021-27292 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2021-27292, GHSA-78cj-fxph-m83p, UBUNTU-CVE-2021-27292.

Is CVE-2021-27292 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free