# CVE-2021-27292: Regular Expression Denial of Service (ReDoS) in ua-parser-js

> Attackers can cause denial of service in applications using ua-parser-js by sending malicious User-Agent headers that trigger excessive regex processing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-27292, GHSA-78cj-fxph-m83p, UBUNTU-CVE-2021-27292

## What is CVE-2021-27292?

CVE-2021-27292 is a high-severity denial of service vulnerability in n/a, published on 17 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.

## Which versions are affected by CVE-2021-27292?

2 open source packages ship an affected version, including ua-parser-js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ua-parser-js` | npm | From 0.7.14 | 0.7.24 |
| `ua-parser-js` | npm | From 0.7.14 | 0.7.24 |

Products: Ua-Parser-Js Project Ua-Parser-Js.

## How do I fix CVE-2021-27292?

Upgrade ua-parser-js to 0.7.24 or later.

## Is CVE-2021-27292 being exploited?

There is no known exploitation of CVE-2021-27292 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-48125](https://insights.sbomify.com/CVE-2026-48125/): UAParser.js: Unbounded `Sec-CH-UA-Model` parsing can trigger ReDoS in `withClientHints()` (medium 5.3)
- [CVE-2022-25927](https://insights.sbomify.com/CVE-2022-25927/): ReDoS Vulnerability in ua-parser-js version (medium 5.3)
- [CVE-2021-4229](https://insights.sbomify.com/CVE-2021-4229/): ua-parser-js Crypto Mining backdoor (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27292 and fix it if it is affected.

What it is: CVE-2021-27292 is a high-severity denial of service vulnerability in n/a, published on 17 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-27292 in the wild and no public exploit code.

Affected packages and fixed versions:
- ua-parser-js (npm): affected from 0.7.14; fixed in 0.7.24
- ua-parser-js (npm): affected from 0.7.14; fixed in 0.7.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27292/ (Markdown: https://insights.sbomify.com/CVE-2021-27292/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27292
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27292
- OSV: https://osv.dev/vulnerability/CVE-2021-27292

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27292/
Summaries are generated and may contain mistakes; the official description above is the record.
