{"answers":{"affected":"1 open source package ship an affected version, including rum. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-27308 in the wild and no public exploit code.","fix":"Upgrade rum to 1.8.1 or later.","what":"CVE-2021-27308 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Mar 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-27308 and fix it if it is affected.\n\nWhat it is: CVE-2021-27308 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Mar 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-27308 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rum (Bitnami): affected from 1.8.0; fixed in 1.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-27308/ (Markdown: https://insights.sbomify.com/CVE-2021-27308/index.md)","id":"CVE-2021-27308","markdown":"https://insights.sbomify.com/CVE-2021-27308/index.md","name":"CVE-2021-27308","record":{"aliases":["BIT-rum-2021-27308","GHSA-r57m-c9hr-x87c"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"4images CMS","requires_auth":"high_privilege","summary":"Remote attackers can inject JavaScript into the admin login panel via the redirect parameter, potentially compromising administrator sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"4images","vendor":"4homepages"}],"cvss":{"score":4.8,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A cross-site scripting (XSS) vulnerability in the admin login panel in 4images version 1.8 allows remote attackers to inject JavaScript via the \"redirect\" parameter.","ecosystems":["Bitnami"],"exploits":{"exploitdb":1,"first_seen":"2021-06-03","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2021-06-03","kind":"exploitdb","ref":"49945","stars":null,"title":"4Images 1.8 - 'redirect' Reflected XSS"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Cross-site scripting in n/a","id":"CVE-2021-27308","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":1,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2021-27309"},"packages":[{"ecosystem":"Bitnami","fixed":["1.8.1"],"introduced":["1.8.0"],"last_affected":[],"package":"rum","purl":"pkg:bitnami/rum","source":"BIT-rum-2021-27308"}],"prev":{"headline":"Auth bypass in n/a","id":"CVE-2021-27306"},"products":["n/a"],"published":"2021-03-22","related":[{"cvss_score":8.6,"headline":"4images 1.9 - Remote Command Execution (RCE)","id":"CVE-2022-50806","kev_date_added":null,"published":"2026-01-13"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2012-1022","kev_date_added":null,"published":"2012-02-08"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2006-5236","kev_date_added":null,"published":"2006-10-11"},{"cvss_score":6.8,"headline":"Path traversal in n/a","id":"CVE-2009-2132","kev_date_added":null,"published":"2009-06-19"},{"cvss_score":5.8,"headline":"Open redirect in n/a","id":"CVE-2012-1023","kev_date_added":null,"published":"2012-02-08"},{"cvss_score":4.8,"headline":"Cross-site scripting in n/a","id":"CVE-2020-35853","kev_date_added":null,"published":"2021-01-25"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Remote attackers can inject JavaScript into the admin login panel via the redirect parameter, potentially compromising administrator sessions.","url":"https://insights.sbomify.com/CVE-2021-27308/"}