# CVE-2021-27376: nb-connect invalidly assumes the memory layout of std::net::SocketAddr

> The nb-connect Rust crate allows invalid memory access via unsafe casts, potentially leading to crashes or code execution.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-rm4w-6696-r77p, RUSTSEC-2021-0021

## What is CVE-2021-27376?

CVE-2021-27376 is a critical memory corruption vulnerability in n/a, published on 18 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the nb-connect crate before 1.0.3 for Rust. It may have invalid memory access for certain versions of the standard library because it relies on a direct cast of std::net::SocketAddrV4 and std::net::SocketAddrV6 data structures.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2021-27376?

3 open source packages ship an affected version, including nb-connect. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nb-connect` | crates.io | All versions | 1.0.3 |
| `nb-connect` | crates.io | All versions | 1.0.3 |
| `nb-connect` | crates.io | From 0.0.0-0 | 1.0.3 |

Products: Nb-Connect Project Nb-Connect.

## How do I fix CVE-2021-27376?

Upgrade nb-connect to 1.0.3 or later.

## Is CVE-2021-27376 being exploited?

There is no known exploitation of CVE-2021-27376 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27376 and fix it if it is affected.

What it is: CVE-2021-27376 is a critical memory corruption vulnerability in n/a, published on 18 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-27376 in the wild and no public exploit code.

Affected packages and fixed versions:
- nb-connect (crates.io): affected all versions; fixed in 1.0.3
- nb-connect (crates.io): affected all versions; fixed in 1.0.3
- nb-connect (crates.io): affected from 0.0.0-0; fixed in 1.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27376/ (Markdown: https://insights.sbomify.com/CVE-2021-27376/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27376
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27376
- OSV: https://osv.dev/vulnerability/CVE-2021-27376

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27376/
Summaries are generated and may contain mistakes; the official description above is the record.
