# CVE-2021-27377: Use-after-free in yottadb

> A use-after-free vulnerability in the yottadb Rust crate allows attackers to potentially execute arbitrary code or cause a denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-9658-c26v-7qvf, RUSTSEC-2021-0022

## What is CVE-2021-27377?

CVE-2021-27377 is a critical use after free vulnerability in n/a, published on 18 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the yottadb crate before 1.2.0 for Rust. For some memory-allocation patterns, ydb_subscript_next_st and ydb_subscript_prev_st have a use-after-free.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2021-27377?

3 open source packages ship an affected version, including yottadb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yottadb` | crates.io | All versions | 1.2.0 |
| `yottadb` | crates.io | All versions | 1.2.0 |
| `yottadb` | crates.io | From 0.0.0-0 | 1.2.0 |

Products: Yottadb Yottadb.

## How do I fix CVE-2021-27377?

Upgrade yottadb to 1.2.0 or later.

## Is CVE-2021-27377 being exploited?

There is no known exploitation of CVE-2021-27377 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27377 and fix it if it is affected.

What it is: CVE-2021-27377 is a critical use after free vulnerability in n/a, published on 18 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-27377 in the wild and no public exploit code.

Affected packages and fixed versions:
- yottadb (crates.io): affected all versions; fixed in 1.2.0
- yottadb (crates.io): affected all versions; fixed in 1.2.0
- yottadb (crates.io): affected from 0.0.0-0; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27377/ (Markdown: https://insights.sbomify.com/CVE-2021-27377/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27377
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27377
- OSV: https://osv.dev/vulnerability/CVE-2021-27377

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27377/
Summaries are generated and may contain mistakes; the official description above is the record.
